EZSrve loses time 2009-10-23T05:37:47+00:00

HOME Forums Gateways EZSrve EZSrve loses time

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • Anonymous
    Post count: 12
    #40221 |

    I have an EZSrve running firmware 1.60. Lately it doesn’t seem to pick up the correct date and time after a power failure. It is set to use NTP in the configuration page, and is set to DHCP in the Net configuration page. It has the correct gateway address.

    I’m pretty sure that it was able to do this at some point, but I noticed yesterday after a power failure that it had the wrong time. I’ve restarted it through the web interface, and pulled the plug on it, and it doesn’t restore the correct date and time. How long should it take to get the date and time after it is restarted? What else must I do for it to be able to get the date/time from NTP?

    Thanks.

    Anonymous
    Post count: 1001

    After setting the NTP option and the appropriate Time Zone, when the correct date and time are displayed, click on SET TIMEZONE button. You can test if this is successful by doing a Restart (not Reset) or unplugging the unit.

    Anonymous
    Post count: 12

    It doesn’t work. First I set the correct time manually (almost; I set it 10 minutes fast so I would be able to see if it ever updated the time), and then I enabled the NTP option. It never corrected the time; 24 hours later when I looked it it, the time was still 10 minutes fast. When I restarted it, the date/time was reset to noon (12:00) on 1/1/2007. Pressing the “set timezone” button doesn’t seem to have any effect. Also, the “Daylight Savings Time” checkbox (as well as the time and date fields) is insensitive when the NTP option is selected; how does the device know whether I’m in a state/region that doesn’t observe DST or a one that does?

    How do I get NTP to work? Do I need to have a NTP server running on my local network, or will the EZSrve connect to a time server through my router? The documentation says it can connect to a time server on the internet if it has internet connectivity, but that doesn’t seem to be working.

    Anonymous
    Post count: 1001

    Set the NTP option and the Time Zone that is applicable. I believe the Network Time Protocol requires a Time Zone. When the NTP option and Time Zone are set the date/time should be correct. Then click on SET TIMEZONE to make the definitions permanent.

    You did not mention setting the Time Zone value. Does setting a Time Zone value present a problem?

    Anonymous
    Post count: 12

    Setting the Time Zone field doesn’t make a difference. No matter what it is set to, checking the NTP option and pressing the “set timezone” button does not change the date/time. I would expect that changing the timezone should cause the time to be offset appropriately, but that doesn’t happen, which is another indication to me that the EZSrve is not contacting a time server.

    One thing that I noticed is that as soon as I change the Time Zone setting, the page refreshes before I can press the Set Timezone button. This happens with Firefox 3.5, and with IE8 in both normal and compatible modes. If I do nothing, the page still refreshes every 5 seconds.

    Anonymous
    Post count: 1001

    Setting the correct time zone and setting the NTP option should result in the current date/time for that time zone being displayed. Clicking the set timezone button is not necessary for the current date/time values to be displayed. If that does not happen then getting the date/time to survive a power cycle is secondary at this point. Could be something is blocking EZSrve access to the internet or blocking the response back to the EZSrve IP address.

    Anonymous
    Post count: 12

    I put the EZSrve outside my firewall (made it the DMZ host in my router) and it works. Then I turned off the DMZ setting, because I really don’t want the EZsrve to be exposed on the ‘net, and tried it again, and it still works. I’m not sure what I did, but it’s working now.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.