zbpserver uninstall reinstall error [SOLVED] 2015-06-19T01:37:29+00:00

HOME Forums Gateways Raspberry Pi zbpserver uninstall reinstall error [SOLVED]

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • Anonymous
    Post count: 5
    #40475 |

    I’m trying to set up my USB-CID. I successfully installed zbpserver and it was running on the rpi. I connected with the smartenit app, but I had some connection errors (my wifi’s fault) while setting the password, pin and reset email. It seemed to finally take, but I couldn’t authenticate, said I had wrong password. email reset didn’t work. so, I thought I would uninstall and reinstall the zbpserver and start again. So, I did this:

    sudo apt-get purge zbpserver;sudo apt-get autoremove;sudo apt-get clean

    and then I did this:

    echo ‘echo “deb http://repo.smartenit.com/v2 raspbian/stable main” >> /etc/apt/sources.list’ | sudo -s;sudo apt-get update;sudo apt-get install -y –force-yes zbpserver;

    but, I got this error:

    Adding system user zbp….done
    /var/lib/dpkg/info/zbpserver.postinst: 64: /var/lib/dpkg/info/zbpserver.postinst: zbpserverconfig: Permission denied
    dpkg: error processing zbpserver (–configure):
    subprocess installed post-installation script returned error exit status 126
    Errors were encountered while processing:
    zbpserver
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    and now zbpserver is not running. What should I do?

    Anonymous
    Post count: 5

    Can anyone assist me with this problem?

    Anonymous
    Post count: 2

    I was having this exact same problem until today. I ran a ‘sudo apt-get update’ and ‘sudo apt-get upgrade’ while trying to do something else, and it tried to install it again and it worked. They may have fixed the issue and updated the files in the repository.

    Anonymous
    Post count: 5

    thanks! I actually solved it by doing a
    find / -name ‘zbpserverconfig’
    (I’m only saying that because I forgot where it was, something like /usr/bin), then doing a
    chmod u=rwx,g=rwxs,o= zbpserverconfig
    then running
    zbpserverconfig –force

    …but I think your solution sounds easier!

    Anonymous
    Post count: 259

    We had an issue in the package that was released incorrectly.

    Sorry about the glitch. All should be good now. Let us know if you are having issues.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.