unable to upgrade from beta 2009-08-20T05:02:23+00:00

HOME Forums Gateways EZSrve unable to upgrade from beta

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • Anonymous
    Post count: 3
    #40205 |

    I have a 2.0-Beta of EZSrve installed (reports itself as 02.00.35) and have been unable to upgrade it.

    Starting with essentially blank/reset/default settings and ensuring that DHCP is enabled, attempting to install 2.03 appears to succeed but reboot results in the EZSrve just hanging, not responding and both the leds remain on solid. “hard” reset has no effect. power cycling has no effect. Java tool can’t see it. No network response from it whatsoever. Never even asks for an ip address for itself from dhcp.
    Using tftp I can bring it back up as 2.0-beta and it seems to work again.

    Tried using the java tool to upgrade, the tool claims the upgrade succeeds but on reboot the device hangs, leds on solid, no longer visible to java tool or browser or ping, same as before. “hard” reset and/or power cycling have no effect. Only tftp back to 2.0-beta seems to be able to bring it back to life.
    Now that I’ve got the hang of this tftp thing, I tried tftp to bring it up to 2.03, but on reboot I get the same hang, same solid leds, same lack of network response. tftp back to 2.0-beta again.

    Based on some of the forum posts it seemed worth downgrading to 1.x and trying the upgrade from there. 1.59 being the last pre-2.x firmware I had lying around, I tried loading that up only to encounter the very same device hang, solid leds and no network response. That’s really odd because it was running that one before the 2.0-beta came along. Nevertheless, it’s tftp back to 2.0-beta again to revive it. Gave 1.56 a try as well, just to be thorough, but got the same result and so back to 2.0-beta again.

    Using the java tool I find that I can try to downgrade to 1.60 even though I don’t have copy of that one downloaded anywhere, but alas, it hangs with that one too.

    Running out of other things to try, I even uploaded the 2.03 image.bin via ftp to the device, but unsurprisingly it hangs on reboot.

    So somehow it seems I’m stuck with 2.0-beta, as no other version, older or newer, will boot up.

    Any suggestions to getting this working again would be much appreciated.

    Anonymous
    Post count: 3

    Just saw that 2.04 was released. Used the Java tool to upgrade, it reported success, reboot hangs the device just like the other upgrades attempts.

    Anonymous
    Post count: 1001

    Are you set up to handle DHCP mode for EZSrve.

    Anonymous
    Post count: 55

    The only thing I can think of is to be sure you actually start from clean files before you go to different firmware. I’ve found that the “reset” functionality in the HTML interface and the Discovery tool doesn’t work 100% of the time, particularly if the firmware isn’t working correctly. I’ve recently had situations while troubleshooting 2.04 where the reset button reset the devices file but didn’t reset the actions file (the EZSrve reboots itself if during load of the actions file it finds a reference to a device that isn’t in the devices file). I’ve gotten into the habit of actually looking at the files to be sure they are defaults.

    The other thing I remember is that early versions of 2.XX didn’t automatically update the devclusters.xml file. I suspect that the devclusters file with the 2.0 beta are out of date. So if you could get back to a 1.XX firmware going from there to 2.03 or 2.04 might avoid any leftovers from the beta.

    I do have a copy of 1.60 that I’d be happy to send you if you provide an address.

    Good luck.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.