Unable to modify scenes with uploaded scenes.xml file. 2008-07-22T18:48:30+00:00

HOME Forums Gateways EZSrve Unable to modify scenes with uploaded scenes.xml file.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • Anonymous
    Post count: 29
    #40019 |

    I am not able to restore scenes with an uploaded scenes.xml file or edit the scenes.xml file and change the EZServe scenes. Once I did manage to edit the default_01 scene and see that change in the EZServe but have not been able to do it since. Can anyone repeatedly make scene changes by editing their scenes.xml file and uploading it.

    List Files shows the updated file but the scenes gui does not show the scenes.

    EZServe v1.53, Safari on Mac OS X

    Anonymous
    Post count: 1001

    Did you do a restart (not reset) after uploading the new scene xml file?

    EDIT: I added an additional Scene to my scenes.xml by copy/paste of an existing entry and changing the Scene name and Group number. Uploaded the scenes.xml file. Message said successfully uploaded and Restart required. Did Restart, can see the new Scene by doing another List Files and looking at the scenes.xml file but the Scene GUI does not show the new Scene. Tried the SYNCH DEVICES button because links did not exist for new scene but that did not cause the new scene to be visible in the Scenes GUI screen.

    EDIT2: Changed the name of the second Scene which was in the original scenes.xml thinking that the third scene (the one I added manually) did not show because of a scene count somewhere that was not being updated. Same no change result. See the new Scene name in the List Files scenes.xml display but the Scenes GUI still shows old name and does not show the scene I added manually. Did do a restart.

    EDIT3: Added a new Scene through the Scene GUI. Links were successful. The GUI added scene is third in the list, where the manually added scene should have been (and was when looking at the scenes.xml file from the List File function). The second scene name in the scenes.xml file from the List File function no longer has the extra character I added on the end of the scene name and the GUI added Scene is third in the file. The Upload File function puts the scenes.xml somewhere where it will be retrieved by the List File function but does not update what EZSrve is using during its execution. Manual changes to the scenes.xml are not visible during EZSrve GUI functions and GUI updates to the scene list is done against the original (non manually modified version) and eliminates access to the manually modified version by the List File function.

    Summary: Upload File brings in the new scenes.xml file but does not make it accessible to EZSrve runtime, even with a Restart. EZSrve runtime continues to operate against the old scenes.xml file, applying any runtime GUI changes to the original scenes.xml file. I’m done.

    Anonymous
    Post count: 29

    Well put grif. You described my symptoms quite well and thoroughly.

    Thanks,

    loafbread

    Anonymous
    Post count: 1001

    I updated Paul with some additional data this afternoon. Image 1.54 will be available in a couple of days, resolving some issues that surfaced during 1.53. Don’t know if this specific problem will be resolved in 1.54. We will have to test this one when the new image is available.

    Anonymous
    Post count: 408
Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.