trouble talking to the EZIO8SA 2012-12-08T22:32:13+00:00

HOME Forums Input/Output EZIOxx trouble talking to the EZIO8SA

Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts
  • Anonymous
    Post count: 11
    #40353 |

    I recently bought two EZIO8SA with two EZIOComm PLM’s.

    I’ve connected one EZIO8SA to a PLM with the provided ethernet cable and plugged the PLM into the wall. The other PLM is installed in the wall and connected to my computer via a serial cable. When I enter the correct com port, PLM radio button and then select the Connect button, I get the PLM connected to my computer. When I go the the EZIOxx tab and enter “EZIO8SA” and the address of the PLM connected to the EZIO8SA, the utility tries to connect four times and then finally gives me a timeout message.

    I’ve tried swapping PLM’s and EZIO8SA to see if there was a problem with any of them, but I get the same results.

    I’ve included a screen shot of the SUS displaying the status of the connection.

    My ISY can connect and interact with the EZIO8SA, so it seems to be seen on the insteon network.

    Is there something I’m missing finding the EZIO8SA with SUS?

    [attachment=0:1upxoo5q]EZIO8SA connection.png[/attachment:1upxoo5q]

    Anonymous
    Post count: 1001

    If the ISY can talk to the EZIComm connected to the EZIO8SA and the other EZIComm cannot what are the EZIComms plugged into when using the SHN Utility? Any change a surge strip is being used that is absorbing the Insteon powerline signals.

    Do these EZIComm devices have a passthru outlet on the fact of the device

    Anonymous
    Post count: 11

    My old 2412 PLM has died, so I only have the 2 EZIOcomms. When my computer isn’t plugged into one, I have one plugged into the ISY and the other into the EZIO8SA. I removed the EZIOcomm from the ISY to try and program it, so when using the SHN utility, I’m only using one PLM plugged into one EZIO8SA and the other into the serial port on my computer.

    The EZIOcomms have no pass through outlet. There’s no power bars being used. I’ve tried plugging the PLM into different outlets throughout the house with no success.

    Anonymous
    Post count: 1001

    When the EZIComm is connected to the ISY the ISY can communicate with the EZIO8SA. When the EZIComm is connected to the Serial port on the PC the SHN Utility using that EZIComm will not talk to the EZIO8SA. If that is correct is the EZIComm plugged into the same outlet when using the ISY and when it is connected to the PC.

    The ISY shows the EZIO8SA address as 1E.80.BA

    Anonymous
    Post count: 11

    You are correct.

    I hadn’t tried plugging the computer into the PLM in the same location that it’s plugged into the ISY. So I took my laptop down to the “dungeon” and unplugged the ISY and plugged in the computers serial port. Still no joy.

    The ISY “sees” the same address as I’m inputting into the SHN utility.

    Anonymous
    Post count: 1001

    This is what I think the situation is

    EZIComm A connected to the ISY has no problem communicating with EZIComm B connected to the EZIO8SA

    EZIComm A connected to computer serial port, using the SHN Utility, cannot communicate with EZIComm B connected to the EZIO8SA.

    The screen capture shows the SHN Utility connected to an EZIComm (firmware v.9C) successfully as the detail tabs across the top are displayed. The SHN Utility uses the same Serial PLM commands as the ISY is using yet one works the other does not.

    There could be issues with the lap top plugged into the same location as the ISY/PLM causing communications problems but the ISY would also have trouble communicating.

    I have no explanation for these results. The EZIComm B will ultimately not work with the EZIO8SA but it has to do with the location of the link records, not the ability to do basic communication with EZIComm B. Sorry, but I am at a lose to suggest the next step.

    Anonymous
    Post count: 11

    After posting this on the Smarthome forum it was suggested to post the insteon traffic for the device.

    Lee states “The PLM is indicating an unknown type of PLM (3.2A) and it is not acknowleging(echoing) the issued Serial command. Without the echo the PLM is not sending anything on the powerline.” and recommends contacting simplehomenet.

    Is there anything this might suggest to anyone on this forum?

    [attachment=0:3ndi1hn2]EZIO8SA connection.png[/attachment:3ndi1hn2]

    Anonymous
    Post count: 1001

    I am the same person, just a different ID on the other forum. There should be entries in the right pane reflecting the commands issued in the left pane. Even if the EZIO8SA did not respond over the powerline the PLM must echo the serial command back to the SHN Utility. The lack of any echo from the PLM is an issue by itself. It indicates the PLM did not accept the serial command. Even if it was an invalid serial command the PLM is expected to echo the command back with a NAK. In addition the PLM identified itself as a Type 3.2A which is not listed as any PLM type I am familiar with.

    These are what is expected from the PLM for the initial connection to an EZIO8SA. These should appear in the right pane

    1 :9 0262 0DFC71 032800 06
    1 :11 0250 0DFC71 13AC99 2B2800
    1 from ID:0D.FC.71 flags:2B cmd1:28 cmd2:0
    2 :9 0262 0DFC71 032B48 06
    2 :11 0250 0DFC71 13AC99 2B2B28
    2 from ID:0D.FC.71 flags:2B cmd1:2B cmd2:28
    3 :9 0262 0DFC71 030F00 06
    3 :11 0250 0DFC71 13AC99 2B0F00
    3 from ID:0D.FC.71 flags:2B cmd1:F cmd2:0
    4 :9 0262 0DFC71 030D00 06
    4 :11 0250 0DFC71 13AC99 2B0D01
    4 from ID:0D.FC.71 flags:2B cmd1:D cmd2:1

    I am not an SHN employee. I do support the SHN Utility Suite, having added the PLM support code many years ago so I am very familiar with the PLM.

    Anonymous
    Post count: 1001

    What operating system is the SHN Utility running on?

    The PLM responses come back on a separate thread. Perhaps there is an OS issue with the threading on the OS.

    Anonymous
    Post count: 11

    I am running Windows 7.

    Could there be a problem with the serial cable. I never received a serial cable with the units I purchased and so am using one I found in my “old computer stuff” drawer.

    Anonymous
    Post count: 1001

    If you have the original box the 2412 came in the serial cable is packaged inside the folds of the inside cardboard support. I don’t think it is the cable as the PLM did respond to the initial query to get the type of device. That write/read activity is done inline, before the threads are started. The remainder of PLM responses are posted to a separate thread by the OS.

    I do not run window 7. Are there any options that are required/available to run an application as an XP application rather than a native window 7 app.

    Anonymous
    Post count: 192

    Lee, May not be relevant to this problem but I have run the SHN Program on Windows 7 64 bit SP1. With the latests updates added before trying it.
    It would not run until I set the compatibility settings for the SHN exe file to “Run As Administrator”
    This was with a 2413S PLM. Accessing an old hardware revision EZIO2x4.

    Anonymous
    Post count: 1001

    bbrally

    Try the option Brian mentioned.

    BLH

    Thanks very much Brian. I don’t have any window 7 let alone a 64 bit machine. Running in the dark ages.

    Anonymous
    Post count: 11

    I tried running as administrator, running in XP compatibility mode. I removed every frewall/blocking program I could think of and still no connection. I am running 64bit Windows 7 with latest updates, but perhaps this is a PLM issue as Lee has alluded to.

    I’m going to try and call Simplehomenet this morning.

    Thanks for everyones help.

    Anonymous
    Post count: 11

    I talked to SHN and they determined the problem was one of the PLM’s. After finally getting a replacement, I still can’t get it to work. I can still connect my computer to the PLM, but not to the EZIO8.

    This new PLM is different from the previous one. I now have two 5010K PLM’s. Both have the exact same sticker, but the new one has a grounded, three prong plug and a pass though outlet. The old one has only a two prong plug and no pass through.

    I am powering the EZIO8 with the supplied power adapter. I’ve tried swapping the PLM’s and have tried both EZIO8’s with no success.

    As was mentioned in the following forum topic, when I press the “all on” output button, I can hear the EZIO relays clicking and then the SHN utility retires resending the data again.
    http://simplehomenet.com/forum/viewtopic.php?f=5&t=839

    I’ve attached a screen shot showing a trace of the traffic. The first four are the inital attemp to contact the EZIO and the second four are when I pressed the “all on” button.

Viewing 15 posts - 1 through 15 (of 26 total)
  • You must be logged in to reply to this topic.