Time Sync Issue 2016-05-24T23:56:47+00:00

HOME Forums Gateways Harmony P2 Time Sync Issue

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • Justin
    Post count: 146
    #40501 |

    Hello all,

    Many of you have probably noticed that your Harmony P2 no longer knows what time it is and your Wizards may not be firing at the right times, if at all.

    There has been a change to the time server, beyond our control, but we have a patch to change the time server which will require an upgrade.

    Unfortunately, the Harmony P2 will not always upgrade through the iSmartenit application due to a known bug we have resolved with this upgrade as well…so you’ll need to upgrade through SSH.

    If you don’t know how to do that or are not comfortable logging in through SSH…give us a call and we can do it for you through TeamViewer in about 5 minutes.

    !!WARNING!! – If you’re not familiar with SSH and Linux commands, please don’t attempt this as you may corrupt your gateway by typing the wrong thing !!WARNING!!

    But, if you’re up for the challenge, simply follow these steps:

    1) SSH into Harmony P2 (default credentials – User: root, password: Smartenit@105)

    2) Check the repository that your gateway would be getting the ZBPServer from…which should be deb http://repo.smartenit.com/v2 p2/stable main
    – You can check using cat /etc/zpt/sources.list
    – if it is not the correct repository, you can change that using vi (if you don’t know how to do this, you probably shouldn’t be trying to do anything in SSH)

    3) Then simply type zbp-upgrade and wait for it to finish.

    4) At the end of the upgrade reboot the gateway using the reboot command or /sbin/reboot

    After rebooting is complete, go to your “Location Settings” in the iSmartenit application at verify that the time is correct.

    If it is not correct still, re-enter your postal code, save it, go back, and then check it again after a minute.

    We sincerely apologize for this inconvenience.

    Feel free to contact me with any questions.

    Post count: 146

    There is another upgrade available for the Harmony P2 that fixes the issue of needing to power cycle the gateway if the PLM is unplugged and plugged back in.

    If you have already upgraded before for the time sync issue using SSH, you can upgrade to version 2.4.0 by simply typing zbp-upgrade at the command prompt.

    Alternatively, you can upgrade the gateway from the iSmartenit app under the Information area of the gateway. (Click the “i” button when you’re at the page where you would enter the IP addresses).

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.