SimpleHoneNet Utility Doesn’t 2007-09-25T14:28:54+00:00

HOME Forums Software SimpleHomeNet Utility SimpleHoneNet Utility Doesn’t

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • kenburkhalter
    Post count: 0
    #39788 |

    I have tried unsuccessfully now about a half dozen times to get the Simplehomenet Utility Suite application running. I have uninstalled and reinstalled NetFrameWork software trying versions 2.0 and now 3.5 (as I understand NetFrameWork is needed).

    I have installed the earlier and now the updated 1.1 version of the Utility Suite, but to no avail.

    I am running in an XP invironment. (Although I also tried to install the Utility on a Vista computer for comparison and got the same (no results) outcome.)

    hen I run the setup.exe that unzips from the suite download. It either immediately terminates with a “,,, installation has encountered a problem …” message or on some prior attempts seems to run, but even then produces no workable results. Attempting to execute the program load that results from these instances, never does anything. There is a few second burst of CPU activity and then nothing ever comes of it.

    Please advise what is needed to install this Utility so I can use my EZIO8T controller.

    Thanks! 🙁

    Anonymous
    Post count: 408

    You do need .NET 2.0. If you want to use the PLC, you also need to install the Smarthome Device Manager

    http://www.simplehomenet.com/Downloads/SetupSmarthomeDeviceManager3-308.exe

    It sounds like you are running the setup file from within the compressed file.
    When you download the .zip file, unzip EVERYTHING into a new directory. Run setup.exe from that new directory, not from within the .zip file. If you are having a problem unzipping the file, I am a big fan of 7zip

    http://www.7-zip.org/

    Once the utility is installed, you can delete the directory you created and everything within it.

    If that doesn’t work for you, please post the error message you are getting and we can go from there.

    kenburkhalter
    Post count: 0

    Paul – thanks for your assistance.

    Wow. That is not good news. I had NetFrameWork 2.0 installed and it didn’t seem to work so I then upgraded to version 3.5. Also I was runing the setup file from the unzipped download.

    I do note that the unzipped data seems unusual in that in addition to the setup file there are: Simplehomenet Utility Suite.application; and Simplehomenet Utility Suite_1_1_0_0.application files and a Simplehomenet Utility Suite_1_1_0_0 folder containing 3 files with strange “extensions” of ‘deploy’ and ‘manifest’.

    I noted from your download area that the Device Manager was ‘required’ for use with the Utility and thought perhaps that was my problem, and already tried to run the Device Manager, but when I attempt to do so I get an immediate “corrupted package; incorrect TMP/TEMP variables; or there is no execute permission for temporary folder” error.

    Again I am doing all this on a new XP machiine (with all SvcPaks installed) and virtually no other software except SmartHomes HouseLink). This is my home automation computer and is running nothing else so it seems unlikely there are any conflicts. But nothing from SimpleHomenet seems to work!

    Any more ideas?

    Anonymous
    Post count: 408

    We are releasing a new version in 1-2 days, standard .msi format for the release, aka double click and install. Version 1.2 will primarily be released for improved EZBridge detection and resolving a bug relating to factory resets. So, I would recommend waiting 1-2 days if you can for that release. If not, let me know.

    kenburkhalter
    Post count: 0

    Paul – I can indeed wait.

    To make sure things go well can you advise an overview of the install process?

    ie must I uninstall old SW; What system requirments (.net, etc) are needed?

    I only need to use the PLC to program the EZIO8T, thereafter the EXIO8T will be in the garage to turn on/off lights when the door opens and closes. Thus do I need the Device Manager at all?

    Thanks for all your help.

    PS – how will I know when the new release is available and where will it be? 😆

    kenburkhalter
    Post count: 0

    Talked with someone there today on phone, but he was harried and only partially helpful.

    In one more effort to get things going I uninstalled all .NET (versions 2, 3, and 3.5 were installed) Framework software, and all your SW using the ‘Add Remove Programs’ Control Panel. Then ran Microsoft’s Uninstall Clenup Utility and then Abexo Registry Cleaner as well as Microsoft Cleaner. Then went thru and made sure there were no Registry entries for any SimpleHomeNet applications, nor any PROGRAM FILES entries for your SW (there were not).

    Then reinstalled .NET2.0 and rebooted.

    Then downloaded your SimpleHomeNet Utility Suite again from your web site to make sure I had a good copy and unzipped it and tried to install it but the install crashes right away with a “Setup has encountered an error and needs to close”.

    I tried this twice with SmartHome’s HomeLink running and not running to see if it made a difference. It did not.

    Sigh. I hope the new release works. I’m at a loss to figure out what is happening. This is a new computer with XP installed and no software on it but HomeLink. It should be as clean of an environement as there is!

    ALSO ANOTHER QUESTION!

    Apparently the documentation you have on your web site and what SmartHome has for the EZIO8T Quick Start manual is wrong!

    Thus I do not have instructions to set up the EZIO8T and link it to a switch just to try it out while I am waiting to get the SW running.

    Your (harried) associate was going to email my the correct documentation but it has never showed up. Thus unless it will be on the web site ASAP, could you please email it to me?

    Thanks. 😕

    Anonymous
    Post count: 408

    Download the MSI and let me know if it works for you

    http://sourceforge.net/projects/shnutilitysuite/

    kenburkhalter
    Post count: 0

    Paul – that was the key. All worked fine without a hitch. I discovered quickly that I need a Help Guide to know what all the settings are! Is there a User Guide that I can download from somewhere (I haven’t found one yet?)

    Also the Utility reinforced my suspicions that I don’t think my EZIO8T unit is working!

    I was unable to (manually) link the EZIO8T to any Insteon devices yesterday (that’s why I talked with Al). Part of the probllem was your web site documentation for the Quickstart Guide is wrong, but even after doing a factory reset and following Al’s instructions I was still unable to link anything or even to get the EZIO8T’s LED to blink as it is apparently supposed to.

    Now with the Utility installed and the EZIOxx Tab open and the “EZIOxx Insteon ID” entered in the data field and the proper device type (EZIO8T) selected, I see a “Not Connected” mesage under the ID Field label. I assume that message is a real-time message that is updated as soon as the ID field is tabbed out of. I could see no other way to force a message update.

    I can read and write the PLC OK, as I set and read back time and lat/long values.

    Any suggestions? Should I ask SmartHome to replace this EZIO8T unit?

    Anonymous
    Post count: 408

    We are currently authoring a guide – sorry for the delay to everyone on that. So, nothing to download yet, sorry.

    In regards to the connections to the EZIO8T, if you cannot connect, go to the insteon tab on top, and look in the received box (right hand side) to see if we are getting ANY insteon traffic from the module. If it is blank, then your suspicions are right, the 8T is not talking.

    However, if the LED is not correct – and you see no traffic on the utility, then I do recommend you return the module to Smarthome – I am sorry for the inconvenience.

    kenburkhalter
    Post count: 0

    OK. FOund out that if I click on a READ button on the EZIOxx tab it then connects to the module and I do then get Insteon traffic. You may want to add this requirement to your new guide or change the software so that when you tab out of the ID address field it automatically connects.

    Re: no guide. Can I impose on you to give me a very brief description (a few screen captures sent to my email address [kenburkhalter@yahoo.com] would probably suffice) on how to make things work? Without a Help menu even, it is not obvious which “unit address” is required in various field (sender or receiver!) and how to set up switch transition states or how I need to set up Input-2 (1-wire?).

    What I want to do is turn on/off my garage lites when the magnetic switch on the door changes state.

    My EZIO8T address is 08.9E.0C and the two lites are on 04.7D.0C and 05.43.5F.

    When the magnetic switch opens (door up) on Input 2 [the other inputs are grounded] I want to turn on both garage lites.

    When the switch closes (door down) I want to turn on both lites for 90 seconds and then turn them both off (gives me time to get out).

    That’s it.

    If you can just tell my what values to enter and where to put them, I’m sure I can figure out the rest.

    I still can’t get the module to manually link but if I can set it up with this SW Utility then manual linking doesn’t matter. If needed I’ll cross the ‘warranty’ bridge if needed.

    Thank you ever so much. You have been remarkably responsive and I much appreciate it!

    😛

    Anonymous
    Post count: 408

    You shouldn’t have to hit the read button…. I will look into that.

    You definitely can impose for some material. I would prefer to post an initial draft to help everyone – target time would be Sunday/Monday ish. In the meantime, give our support line a call, they can walk you through it. If not, send me a message and I will get back to you with the targeted info you are looking for.

    kenburkhalter
    Post count: 0

    Paul – I’ve been patient, but thought I might get something or else missed a response re documentation release and/or a brief answer to my config questions sent to your email address multiple times over the last 5 days, so thought I’d better jump in here again.

    Any progress?

    Also spent the weekend trying to get EZIO8T to work. Still can’t seem to link nor can I get any status change from the input side. I seem to be able to write the outputs and read them back, but the inputs all read OFF.

    I have checked and quadrruple checked that the door switch is wired to pins 4,5 and that the switch provides open/close responses to thos pins measyred at the RJ connector on the end of the cable, but the 8T never seems to notice it. I tried linking to a light switch hoping an input state change would trigger something, but nada. Also confirmed no status change when Inputs were read.

    Should I assume at this time that I have a bad 8T and send it back for a warranty exchange?

    Anonymous
    Post count: 408

    There is a new utility release – see downloads section – v1.3.

    This version now has working electronic link management. Please try to establish a link to the module using the utility. After the link is established, please let me know the status of the input changes.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.