Scenes/Groups not quite right in 1.53 2008-07-17T13:43:20+00:00

HOME Forums Gateways EZSrve Scenes/Groups not quite right in 1.53

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • Anonymous
    Post count: 29
    #40010 |

    I haven’t spent a lot of time on this. I am just putting it out here in case someone else sees it they won’t feel like they are alone.

    I defined about 3 scenes and rebooted the EZServe and it deleted all the Scenes including the Default_01.

    When defining Scenes you have to increment the “Unit” on the controller or the Scenes all get configured with 00. I think that used to auto increment. Now you have to keep track of the last used Scene number.

    Anonymous
    Post count: 408

    We will look into this – thanks for the catch.

    Anonymous
    Post count: 1001

    A different experience with 1.53.

    I am running 1.53 and have not seen the loss of scenes using a Restart. I had scenes from 1.51 and 1.52 which were carried forward into 1.53. Also scenes created on 1.53 remain after a Restart on my system.

    The unit number did not auto sequence on 1.51 or 1.52. I noted this in a post back in June. Would be a nice idea for scenes where EZSrve is the controller. Might be a problem for things like a KPL where someone is trying to add additional devices to the given button number.

    I cannot add a scene with unit number 00. Leaving the unit field blank or setting it to 0 or 00 results in a popup indicating unit number is needed or a valid unit number is needed before a Controller can be added to the Scene.

    Anonymous
    Post count: 29

    Is the “Unit” number the Group number to be used in a SndGrp command?

    Anonymous
    Post count: 1001

    I fired a Timer for Default_01, which is unit/group 01, and then fired a Timer for one of my Scenes which is unit/group 03. The following data is the XML SndGrp from the SHN Utility trace and the Insteon traffic trace from Houselinc for Default_01 followed by the same data for my Scene using unit/group 03 …


    Message : 1:48:59 PM Thursday, July 17, 2008
    :
    :
    SndGrp
    0X2
    0X61
    0X1
    0X11
    0X1
    0X6



    7/17/2008 1:48:59 PM: receiveinsteonraw=02 06 4C A5 00 00 01 CF 11 01
    7/17/2008 1:48:59 PM: eventraw=02
    7/17/2008 1:48:59 PM: eventraw=03
    7/17/2008 1:48:59 PM: receiveinsteonraw=02 06 4C A5 04 56 50 41 11 01
    7/17/2008 1:49:00 PM: eventraw=02
    7/17/2008 1:49:00 PM: eventraw=03
    7/17/2008 1:49:00 PM: receiveinsteonraw=02 06 4C A5 04 93 BF 45 11 01

    Message : 1:55:59 PM Thursday, July 17, 2008
    :
    :
    SndGrp
    0X2
    0X61
    0X3
    0X11
    0X3
    0X6



    7/17/2008 1:55:59 PM: receiveinsteonraw=02 06 4C A5 00 00 03 CF 11 03
    7/17/2008 1:55:59 PM: eventraw=02
    7/17/2008 1:56:00 PM: eventraw=03
    7/17/2008 1:56:00 PM: receiveinsteonraw=02 06 4C A5 04 93 BF 41 11 03

    The Unit number in the Scene definition correlates to the Group number in the SndGrp XML and Insteon Group Broadcast and Group Cleanup Direct message traffic.

    EDIT: Unit/Group/Scene numbers are all the same thing. Would have been nice to use Group Number or Scene Number as the field description rather than use a third term, Unit. Just as a Scene and a Group are the same thing. Smarthome or maybe Smartlabs is responsible for using those two terms that describe the same thing.

    Anonymous
    Post count: 29

    Thanks for the help, I have a lot to learn before this all makes sense.

    Anonymous
    Post count: 1001

    If you have not found it yet, Smarthome has a forum specific to Insteon. Lots of good information over there. I have found that understanding how native Insteon devices work together is a big help in understanding what EZSrve is doing. Insteon architecture has been around long before devices like EZSrve became available. Knowing how the Insteon hardware works with Groups and Links and link databases makes understanding how EZSrve is using those functions and features easier to understand. If you get hung up on something, someone on one of the forums is always more than willing to help.

    The link to the Smarthome forum http://www.techmall.com/default.asp

    Anonymous
    Post count: 1001

    I was adding Insteon devices to EZSrve. Started with 4 Insteon devices and several X10 devices already added during earlier image. Added new Insteon devices 1 through 8, creating links for each during add, all successful. Adding 9th new Insteon device I received the EZSrve Login Screen toward the end of the process. Nothing in the Houselinc trace looked abnormal. When I logged in I was back at the rotating image waiting for the link process to finish for the 9th device. Never finished so I clicked on cancel. Added the 10th new Insteon device successfully. When I went to look at the Scenes to see what was added to Default_01 I found the only thing in Scenes was Default_01 (all my Scenes were gone) and the only device in Default_01 was the 10th Insteon device from above. Something that caused me to have to relogin also destroyed all the Scene data. Macro, Timer and Device XML files look okay.

    Anonymous
    Post count: 408

    Here is the scope of 1.54

    http://www.simplehomenet.com/forum/viewtopic.php?p=2457#2457

    Please let us know if anything is missing

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.