How the new Flash Interface Works 2009-06-24T20:42:32+00:00

HOME Forums Gateways EZSrve How the new Flash Interface Works

Viewing 15 posts - 16 through 30 (of 48 total)
  • Author
    Posts
  • Anonymous
    Post count: 1001

    Try the format http://www.compacta.org/?url=yyy.yyy.y.yyy This gets me to my local EZSrve. It takes several seconds for the Flex client to load from the compacta server on a 1.5 mbp DSL line and then I generally, but not always, have to click on the browser refresh icon to get the login screen to come up on IE8.

    Anonymous
    Post count: 73

    Tried it with /?url=xx.xx.xx.xx. Still get the ‘initializing’ status that never completes.

    Anonymous
    Post count: 1001

    I am out of ideas unless you have not gotten EZSrve fully functional on 02.00 yet.

    Anonymous
    Post count: 73

    After having to recover to 1.60 earlier (see my BRICK post), I updated to 2.0 that I downloaded today, and it took successfully. The unit looks fully operational and shows V 2.00 PLM Ver 63.

    By everything I can tell, it should be working. I’m at work and I’m accessing my EZServ directly with no problems.

    Anonymous
    Post count: 1001

    You did upload DevClusters.xml? I did see that you could access EZSrve with the DHCP assigned IP address.

    Anonymous
    Post count: 73

    Just uploaded the devclusters.xml and restarted the unit… the flash site still doesn’t load completely.

    Anonymous
    Post count: 1001

    If you have added devices before uploading DevClusters you need to delete the devices and readd. The device characteristics will not be correct without the latest DevClusters file in effect when devices are added. We resolved a problem today by deleting/readding devices that had been added without the correct level of DevClusters. Now that you have DevClusters, after the Flex client has completely loaded, try the browser refresh icon and see if that gets you to the login screen.

    Anonymous
    Post count: 73

    I think the problem is that the flex client is not loading completely. I deleted the couple devices that I had added before the DevClusters.xml was uploaded, then restarted the EZServ. Still can’t get past the loading status bar on the client screen. With or without the IP of my device in the URL.

    Anonymous
    Post count: 1001

    Running the Flex client with the SHN EZSrve (no url address) has not worked for some days. Don’t know what changed with that configuration but I have a query into Simplehome about that. Running the Flex client with my EZSrve has been working for along time (with the need to refresh some times to get login screen). Don’t know why you are having a problem unless as you say the network is not bringing down the full client. The Adobe Flash plugins normally stay pretty current so it is probably not a plugin level problem.

    The Device View/Control screen was not displaying device status correctly for devices that were added without the DevClusters file. There is another topic under EZSrve that covers this. Running with the latest level of DevClusters is important for correct device operation in V2.

    Anonymous
    Post count: 1001

    I guess my memory is failing as I thought for sure by connecting to compacta without a ?url I would get the SHN EZSrve but that is not the case. Use http://www.compacta.org/?url=ezsrve.com to get to the SHN EZSrve and http://www.compacta.org/?url=xx.xx.xx.xx where xx.xx.xx.xx is your local EZSrve IP address to run the Flex client on your local EZSrve. I just tried the ?url=ezsrve.com and was successful in running the Flex client against the SHN EZSrve. Sorry for the previous incorrect post information.

    Anonymous
    Post count: 73

    Ok, if I click the first link with ?url=ezserv.com, it loads, and I can sign into it. But if I change that to my IP address, it behaves differently.

    On the former, it shows the loading status like I’ve always seen, but ALSO shows a small circle/clock next to my pointer, then it loads a few moments later. When I go to the latter, I just get the little status block in the middle of the screen with the white bar about 1/3 of the way loaded.

    Added: Do I need to forward any more ports through my firewall/router to the EZServe? Currently only port 80 is forwarded, which allows me to get to it’s HTTP interface just fine.

    Added more: Port 8002 like in the original post of this thread? If so, that’s likely the problem.

    Someone’s gonna need to write a nice concise manual for this. My experience so far has been picking up bits and pieces from different posts here. Makes it feel like I’m a beta tester, not an end user.

    Anonymous
    Post count: 73

    Got home, opened the ports, no joy.

    I also noticed on the device view/control page, the status of the devices are not updating. They will perform the on/off commands, but the status always says OFF.

    Updated, had to delete all the devices and load the devclusters.xml while local and now the status’ show like they should.

    Anonymous
    Post count: 36

    After connecting to login screen of the flash interface using http://www.compacta.org/?url=xx.xx.xx.xx, the password always defaults to Simplehomenet, and not the password I have set on my EZSrv. This is not a good situation security-wise and I hope it is resolved soon.

    Anonymous
    Post count: 256

    The password in the demo software is locked-in to allow multiple people to preview the application. It does not YET use the built-in EZSrve login credentials. The production version will.

    Anonymous
    Post count: 36

    That’s fine. I just don’t want multiple people previewing it on MY EZSrve, which could happen if they discovered my external IP address. Can’t you enable the login credentials and just have the password on the demo unit Simplehomenet?

Viewing 15 posts - 16 through 30 (of 48 total)
  • You must be logged in to reply to this topic.