HomAidPi – is it real? 2012-10-10T14:19:33+00:00

HOME Forums Gateways Raspberry Pi HomAidPi – is it real?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • kevin
    Post count: 2
    #40352 |


    I wonder if you can help…

    It has taken over a week to have my forum registration activated, so that wasn’t a great start and there is no section on your forum for the HomAidPi product, so I really hope support is available for this…?

    You have product called HomAidPi on your home page…..


    it is a version of ZBP Server, running on the Raspberry Pi… …It can connect to all the major devices, Zigbee, X10, Insteon, so ticks all the boxes for me.

    However,when you get to the how to section –

    step 3 and 4 –

    Step 3: Add the following at the end of the sources List

    •pi@raspberrypi ~ $ deb http://harmonygateway.com/repo/ZBPServe … n/arm/RPi/

    Step 4: Update
    •pi@raspberrypi ~ $ sudo apt-get update

    I get an error message when trying to update… It reads:

    E: Malformed line 2 in source list /etc/apt/sources.list (dist)
    E: The list of sources cannot be read.

    I do not know what is causing this, I have added lines to repositories many times before (been using Ubuntu for many years) and google is not helping me find a solution.

    I have downloaded the files and tried to install manually with (sudo dpkg -i zbpserver_1.7-0_arm.deb) but I keep getting dependency errors that I am unable to resolve.

    pi@raspberrypi ~/shn $ sudo dpkg -i zbpserver_1.7-0_arm.deb
    Selecting previously unselected package zbpserver.
    (Reading database … 57974 files and directories currently installed.)
    Unpacking zbpserver (from zbpserver_1.7-0_arm.deb) …
    dpkg: dependency problems prevent configuration of zbpserver:
    zbpserver depends on libqt4-dbus; however:
    Package libqt4-dbus is not installed.
    zbpserver depends on libqt4-network; however:
    Package libqt4-network is not installed.

    dpkg: error processing zbpserver (–install):
    dependency problems – leaving unconfigured
    Errors were encountered while processing:
    pi@raspberrypi ~/shn $ sudo apt-get install libqt4-dbus
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    You might want to run ‘apt-get -f install’ to correct these:
    The following packages have unmet dependencies:
    libqt4-dbus : Depends: qdbus (= 4:4.8.1-1+rpi1) but it is not going to be installed
    Depends: libqt4-xml (= 4:4.8.1-1+rpi1) but it is not going to be installed
    zbpserver : Depends: libqt4-network but it is not going to be installed
    E: Malformed line 3 in source list /etc/apt/sources.list (dist)
    E: The list of sources could not be read.
    E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).
    pi@raspberrypi ~/shn $

    Also tried the network one first, still nothing.

    Is this a real life product that you are marketing or is the Raspberry Pi page simply a well constructed, wind up/joke?

    Thanks for any time you can spare…..

    Post count: 146

    Hi there Kevin!

    Thank you for your post.

    I’m really not sure what happened to your registration for the forum, as I only see the one from yesterday…but our support email or phone number is always the fastest route for tech support.

    I will forward your message to one of our developers to give you some guidance.

    Best regards

    Post count: 2

    Thank you Justin,

    I have an email from your team, I will try this out tomorrow and let you know if it works. It would be good if you could fix this script so new users don’t run into the same problems.

    Thanks again for getting the ball rolling…..



Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.