Help with Timers in 2.0 2009-10-26T05:35:06+00:00

HOME Forums Gateways EZSrve Help with Timers in 2.0

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • Anonymous
    Post count: 1
    #40222 |

    Trying to use the new 2.0 interface. I’m sure it is more powerful but simple, nor comprehendible without something well beyond the instructions it surely is not. Getting rid of the prior simple interface to create timers was a big mistake in my opinion. Now we have actions, effects, values, conditions, booleans, attributes and attribute values. Wow, simple, all plain English…not. OK I’ll stop whining for now. Can someone please just tell me the way to create simple ON/OFF timers for a single device? Please provide exact details as I expect I will never get it without them.

    Anonymous
    Post count: 1001

    This is a V2 Action that turns on 3 different devices (Effects) at 14:00. The EZSrve Operating Guide in the Downloads section has step by step sequence for creating a new Action.

    This post has more examples ….. http://simplehomenet.com/forum/viewtopic.php?f=15&t=668&start=0

    [attachment=1:22zh6p86]ActionsOn.JPG[/attachment:22zh6p86]
    [attachment=0:22zh6p86]ActionsOnCondition.JPG[/attachment:22zh6p86]

    Anonymous
    Post count: 23

    I recently upgraded from 1.5 (1.56? 1.59? I forget exactly which one) to 2.06, and I also find the new actions/conditions/effect/attribute stuff much harder to figure out than the relatively straightforward timer mechanism in the older version.

    I’ve read the Operating Guide (2.0), but it seems woefully inadequate when it tries to explain the Conditions screen at step 4 on page 9. And the paragraph near the bottom of that page isn’t much better.

    I’ve studied some of the examples, but I am unable to get any time-based event to simply turn on an ApplianceLinc.

    I have an ApplianceLinc called “Test”. Through the “Device View/Control” interface I’m able to turn it on and off by hand.

    I have an action called “Test On”, with only “Condition 1” specified (Logic OR, Device=Select Device, Attribute=Select Attribute, Attribute Value=0, At Time: Absolute =, Start Time: 22:21:00, and days Sun through Sat checked), Effect 1 has Device=Test, Attribute=Status, Value=FF (have also tried 1), and delay 00:00:00. The checkbox for Condition 1 is checked, the other conditions are unchecked, and “Action is Enabled” is checked.

    I’ve set the Start Time to a few minutes ahead, saved everything, and waited, but the device never comes on.

    Do I have something missing? Is the Value=FF appropriate for telling an ApplianceLinc to turn on? I’d guess that I’d use 0 to turn it off (but that’s just a guess – I don’t see the ApplianceLinc in Appendix B).

    Help!

    David

    Anonymous
    Post count: 1001

    One user reported that setting the Absolute= time to just a few minutes ahead of current time did not trigger unless the EZSrve was Restarted (not Reset) before the trigger time arrived. I have never been able to recreate that and regularly set time based Actions a few minutes ahead while testing. The parameters you posted look correct. A FF Effect value does turn On an Insteon device and a 00 Value turns an Insteon device Off.

    There are a few areas that if done in the wrong sequence will result in the Action information not saved correctly. You go to the Condition Screen first, set those values and Save on the Condition screen, then click the Back Icon to return to the initial Action screen. Set the Effect information, check the Condition Enable, the Action Enable and click Save on the Action screen.

    Can you post the XML from the Actions.xml file for the Action in question. I will check the actual values saved for both the Condition and Effects to see if I can see a problem. You might try setting an Absolute= time value say 10 minutes in the future, save the Condition and the save the Action. Do a Restart (not Reset) and see if the Action triggers.

    EDIT: There is another possibility I just thought of. Did you check that EZSrve is showing the correct time of day. There were some changes around 1.60 and carried into the V2 images that start off with Manual time zone and no NTP option checked. That will result in EZSrve not running the expected time until the correct time zone is selected, the NTP option checked and the SET TIMEZONE button clicked.

    Anonymous
    Post count: 23

    I tried again this morning, allowing more than 20 minutes from when I set up the action to when it should have triggered. No joy.

    I double, then triple checked, and the clock in the EZSrve is good. It retained the time zone and NTP enabled status from before I did the 2.06 “upgrade”.

    Here’s my entire Actions.xml file (the most recent test case is the 2nd one called Test).

    David

    Anonymous
    Post count: 1001

    Action definition looks fine. The next step is to trace the Action activity. This will show if the Action is actually triggered when expected and what it did if/when it triggered. Version 2 has a telnet based trace that is very good at showing Action processing.

    Open a command window and enter the following commands…

    telnet
    set logfile c:temptelnet.txt
    open 192.168.2.3 10001

    EZServe
    Simplehomenet

    The set logfile command defines the path/file where the telnet trace messages will be written. The example is what I use on my system. Use a path that reflects your system. The open command specifies the IP address of your EZServe. Don’t forget the port number 10001. After the open command, EZServe will prompt for the normal login information. The name EZServe followed by the password. I use the default Simplehomenet password, specify whatever you have defined for the password.

    Set the Absolute= time to something in the future and see what happens. Either post the telnet trace or send it to lwgwork@embarqmail.com. If you restart EZSrve the telnet connection has to be reestablished after the restart.

    Anonymous
    Post count: 23

    grif:

    Looks like the action is getting triggered on schedule at 10:45, but there’s an “Error Sending”:

    Debug Mode started for EZServe
    12/15/2009 10.30.44: In condtn submit: save details cndtn num 1 & Flag 7F
    12/15/2009 10.30.44: In condtn submit: save details cndtn num 1 & Flag 7F
    12/15/2009 10.30.58: Cndtn DMA successful
    12/15/2009 10.30.58: In Submit Action (modify) - CondActive: Selected Action: Test On, IsConditionActive 1, Flag 207F
    12/15/2009 10.30.58: Effect DMA successful
    12/15/2009 10.30.59: ezaction.c - SaveActionsXML closed
    12/15/2009 10.30.59: ReadWriteApi.c - SaveSysVarXML: File Open Success!
    12/15/2009 10.30.59: ezaction.c - SaveActionsSysVarXML Done!
    12/15/2009 10.45.00: In process actions: Activate effect
    12/15/2009 10.45.00: In process actions: Effect to process and action Test On
    12/15/2009 10.45.00: Form clustr: CB-0: [0] CB-I: [0] CB-II: [0] CB-III: [0] CB-IV: [0] CB-V: [0] CB-VI: [0] CB-VII: [0] CB-VIII: [0] CB-IX: [0]
    12/15/2009 10.45.00: In actor requst process: actor queue ActorArray0 0,ActorArray4 0,ActorArray5 0
    12/15/2009 10.45.00: In ezserve admin handler
    12/15/2009 10.45.00: Error Sending
    12/15/2009 10.45.00: ezdevice.c - SaveDeviceXML: File Open Success!
    12/15/2009 10.45.00: ReadWriteApi.c - SaveSysVarXML: File Open Success!
    12/15/2009 10.45.00: ezaction.c - SaveActionsSysVarXML Done!
    12/15/2009 10.46.49: In process post action: make Action status 1

    David

    Anonymous
    Post count: 1001

    The Action triggered at 10:45:00 but did not issue any command to the Effect device. Ignore the Error Sending trace entry. Does not mean what everyone thinks it does. There is a problem with the DevClusters.xml file or the Devices.xml file. How did you install 02.06, with the 1.1 Discovery tool or by directly uploading the image? I’m thinking the DevClusters file is not at the latest level or was not at the latest level when the Test device was added to EZSrve. The Form Cluster trace entry is showing all zeros when it should look something like this with the Insteon command activity that follows. I pulled this from my telnet trace of an Action that is turning Off an ICON Switch.

    12/14/2009 21.58.20: Form clustr: CB-0: [F] CB-I: [4] CB-II: [56] CB-III: [50] C
    B-IV: [11] CB-V: [0] CB-VI: [0] CB-VII: [0] CB-VIII: [0] CB-IX: [0]
    12/14/2009 21.58.20: In actor requst process: actor queue ActorArray0 f,ActorArr
    ay4 11,ActorArray5 0
    12/14/2009 21.58.20: In plm msg handler: msg type Ins std id 04.56.50,0×11 cmd1,
    0x00 cmd2
    12/14/2009 21.58.20: Done: MSG Code 62, ID 04.56.50 Cmd1 11, Cmd2 0 Ack 6
    12/14/2009 21.58.20: Done: PTH_StdMsg 50, ID 04.56.50 Flag 2B, Cmd1 11, Cmd2 0

    I think you need to upload the DevClusters.xml file and then delete and readd the Test device.

    You can send me the DevClusters.xml file and the Devices.xml file and I will verify that or upload the DevClusters.xml file, Restart (not Reset) and readd “Test” device.

    Anonymous
    Post count: 23

    I upgraded by manually downloading the update and using the web interface to specify the new image.bin file.

    Here is my DevClusters.xml:









































































































































































































































































































    Here is my Devices.xml:







































    David

    Anonymous
    Post count: 1001

    The “Test” device definition has no cluster information. Don’t know how that happened. Did you use the HTML interface or the Harmony client to add that device and what type of device is it. Suggest deleting the device and readd. See the cluster information for “Xmas Tree’. This information is missing for the “Test” device.

    Anonymous
    Post count: 23

    w00t.
    I went back to experimenting with the “Xmas Tree” device (since you said my “Test” device was corrupt), and was finally able to get my EZSrve to turn it on! Thanks so much for helping with this.

    My initial experimentation was with the Xmas tree, but I didn’t have the Conditions set up right (I was putting best-guess values into the device fields that I should have left at default values for just a timer), and I couldn’t SEE the tree from my desk, so I started playing with a test ApplianceLinc here beside my desk instead.

    I created the Test device with the web interface. I’ve not tried Harmony.

    I’ve tried deleting the Test device, but it won’t let me. It initially complained that it was used in one of the Actions, so I deleted that. Now it seems happy to let me delete the device, but after the delete process is done (without overt errors), the Test device is still there.

    Can I download the Devices.xml, delete it there, then re-load it?

    I saved all the .xml files before I did the upgrade from 1.5x to 2.0x, but it won’t accept a reload of it. I’ve not yet looked to see what’s different, but if I can hand-hack it and reload it rather than add devices back in one at a time, it would be great.

    David

    Anonymous
    Post count: 1001

    EZSrve will not delete a device definition if that device is referenced in an Action, Area or Scene. All references to the “Test” device must be deleted before the device itself can be deleted.

    You can download the Devices.xml file and manually delete the “Test” device entry, upload the Devices.xml file and do a Restart (not reset). The problem with that is if the device still appears in Scenes, Areas or Actions you have effectively corrupted those definitions by manually removing the “Test” device definition.

    I’ll add an ApplianceLinc to my EZSrve devices to see if I can recreate a device definition without the cluster information. That should be impossible. Were there any error messages, warnings, odd behavior when you added the “Test” device?

    You cannot use V1 xml files (or any part of those files) on V2. They are not upward compatible. Just too many differences between V1 and V2 xml files.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.