GE/Jasco 45857GE In Wall Smart Dimmer Compatibility 2016-04-06T06:23:34+00:00

HOME Forums Software iSmartenit GE/Jasco 45857GE In Wall Smart Dimmer Compatibility

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • Anonymous
    Post count: 19
    #40490 |

    I added the following device to my Raspberry Pi gateway, and surprisingly it didn’t work:

    https://byjasco.com/products/ge-zigbee-wall-smart-dimmer

    Then I looked on the supported devices list and of course it isn’t there. Any chance this can be added to the iSmartenit software compatibility? I can send a wireshark capture of the zigbee association of this device if that will help.

    Here is the REST API output of the capabilities of the device:

    {
    "components": [
    {
    "capabilities": [
    {
    "Basic": [
    {
    "get": [
    "ZCLVersion",
    "ApplicationVersion",
    "StackVersion",
    "HWVersion",
    "ManufacturerName",
    "ModelID",
    "DateCode",
    "PowerSource",
    "LocationDescription",
    "PhysicalEnviroment",
    "DeviceEnabled",
    "AlarmMask",
    "DisableLocalConfig"
    ]
    },
    "status",
    "ResetToFactoryDefaults"
    ]
    },
    {
    "Identify": [
    {
    "get": [
    "IdentifyTime"
    ]
    },
    "status",
    {
    "Identify": [
    {
    "IdentifyTime": "ushort"
    }
    ]
    },
    "IdentifyQuery"
    ]
    },
    {
    "OnOff": [
    {
    "get": [
    "state"
    ]
    },
    "status",
    "Off",
    "On",
    "Toggle"
    ]
    },
    {
    "LevelControl": [
    {
    "get": [
    "CurrentLevel",
    "RemainingTime",
    "OnOffTransitionTime",
    "OnLevel"
    ]
    },
    "status",
    {
    "MoveToLevel": [
    {
    "TransitionTime": "ushort"
    },
    {
    "Level": "uchar"
    }
    ]
    },
    {
    "Move": [
    {
    "Rate": "uchar"
    },
    {
    "Mode": "uchar"
    }
    ]
    },
    {
    "Step": [
    {
    "Mode": "uchar"
    },
    {
    "Size": "uchar"
    },
    {
    "TransitionTime": "ushort"
    }
    ]
    },
    "Stop",
    {
    "MoveToLevelWOnOff": [
    {
    "TransitionTime": "ushort"
    },
    {
    "Level": "uchar"
    }
    ]
    },
    {
    "MoveWOnOf": [
    {
    "Rate": "uchar"
    },
    {
    "Mode": "uchar"
    }
    ]
    },
    {
    "StepWOnOf": [
    {
    "Mode": "uchar"
    },
    {
    "Size": "uchar"
    },
    {
    "TransitionTime": "ushort"
    }
    ]
    },
    "StopWOnOf"
    ]
    },
    {
    "SimpleMeter": [
    {
    "get": [
    "InstantaneousPower",
    "CurrentSummationDelivered",
    "CurrentSummationReceived",
    "CurrentMaxDemandDelivered",
    "CurrentMaxDemandReceived",
    "DFTSummation",
    "Multiplier",
    "Divisor",
    "Current",
    "Voltage",
    "Frequency",
    "KHFactor",
    "MeteringOffset"
    ]
    },
    "status"
    ]
    }
    ],
    "id": "comp1"
    },
    {
    "capabilities": [
    {
    "Basic": [
    {
    "get": [
    "ZCLVersion",
    "ApplicationVersion",
    "StackVersion",
    "HWVersion",
    "ManufacturerName",
    "ModelID",
    "DateCode",
    "PowerSource",
    "LocationDescription",
    "PhysicalEnviroment",
    "DeviceEnabled",
    "AlarmMask",
    "DisableLocalConfig"
    ]
    },
    "status",
    "ResetToFactoryDefaults"
    ]
    },
    {
    "Identify": [
    {
    "get": [
    "IdentifyTime"
    ]
    },
    "status",
    {
    "Identify": [
    {
    "IdentifyTime": "ushort"
    }
    ]
    },
    "IdentifyQuery"
    ]
    },
    {
    "Identify": [
    {
    "get": [
    "IdentifyTime"
    ]
    },
    "status",
    {
    "Identify": [
    {
    "IdentifyTime": "ushort"
    }
    ]
    },
    "IdentifyQuery"
    ]
    },
    {
    "OnOff": [
    {
    "get": [
    "state"
    ]
    },
    "status",
    "Off",
    "On",
    "Toggle"
    ]
    },
    {
    "LevelControl": [
    {
    "get": [
    "CurrentLevel",
    "RemainingTime",
    "OnOffTransitionTime",
    "OnLevel"
    ]
    },
    "status",
    {
    "MoveToLevel": [
    {
    "TransitionTime": "ushort"
    },
    {
    "Level": "uchar"
    }
    ]
    },
    {
    "Move": [
    {
    "Rate": "uchar"
    },
    {
    "Mode": "uchar"
    }
    ]
    },
    {
    "Step": [
    {
    "Mode": "uchar"
    },
    {
    "Size": "uchar"
    },
    {
    "TransitionTime": "ushort"
    }
    ]
    },
    "Stop",
    {
    "MoveToLevelWOnOff": [
    {
    "TransitionTime": "ushort"
    },
    {
    "Level": "uchar"
    }
    ]
    },
    {
    "MoveWOnOf": [
    {
    "Rate": "uchar"
    },
    {
    "Mode": "uchar"
    }
    ]
    },
    {
    "StepWOnOf": [
    {
    "Mode": "uchar"
    },
    {
    "Size": "uchar"
    },
    {
    "TransitionTime": "ushort"
    }
    ]
    },
    "StopWOnOf"
    ]
    }
    ],
    "id": "comp2"
    }
    ],
    "id": 13544,
    "image": "default.png",
    "model": "45857",
    "name": "45857"
    }

    Thanks,
    😀

    Anonymous
    Post count: 259

    The json output of the capabilities of the device is sufficient information. This device can be added dynamically (will get it in mins) 8)

    Can you try the following 2 requests and let me know which one controls the load?

    Request to EP 1:
    curl -X POST "http://local_ip_address:50334/device/13544/comp1/OnOff/Toggle"
    Request to EP 2:
    curl -X POST "http://local_ip_address:50334/device/13544/comp2/OnOff/Toggle"

    Thanks,

    Anonymous
    Post count: 19

    This device can be added dynamically (will get it in mins)

    Sweet!!

    comp1 toggle controls the lights. Toggling comp2 OnOff didn’t have any visible effect. Must be there for a reason though – what do you suppose comp2 controls?

    Regards,
    😀

    Anonymous
    Post count: 259

    Thanks, don’t know, will have to procure the device.

    Compatibility has been added, can you please confirm that it is working through the Smartenit App. You will have to restart the App if it’s open.

    Anonymous
    Post count: 19

    Compatibility has been added, can you please confirm that it is working through the Smartenit App.

    Amazingly fast response, thank you! Indeed, the iSmartenit App does now recognize the device and give me a dimming control for it!

    A few issues I noticed with it during some quick testing:

    – within the App if I drag the slider all the way to 100%, it actually brightens the lights to 95%. I can then drag it to 100% again and it will go to 100%. This is consistent, so it’s not just me fat-fingering the drag. Note I can’t visually tell the difference between 95% and 100% so IDK if the lights are actually at 100% or not.

    – within the App if I drag the slider to 0% it displays 5%, but actually turns the lights completely off (the difference between 5% and 0% is quite obvious). If I drag it again to 0% it now stays there. Again, this is pretty consistent.

    – In a single test, I noticed that if I push the “on” button (by pressing the switch itself manually, outside the App) the App pretty quickly notices this change and updates to say 100%. But if I press the “off” button, the App doesn’t change. I can’t spend 40 minutes right now playing with the lights in the kitchen, my wife and daughter are trying to homeschool in the dining room and that’s very distracting, so this was just a single test.

    – I quickly created a single test wizard in the app using the new kitchen dimmer switch as a trigger for a light in the living room, and it works! The App reports the wizard triggers 4 times for every press of the switch, could this be because I have a fairly dense ZigBee network and multiple routers are rebroadcasting the message? (wild guess on my part).

    – there is no support I can see for the electrical measurement capabilities of this device – the box it came in advertises the fact that it can provide energy usage statistics over time. It would be great to add a wizard that turns the lights off after they have consumed X amount of kWh …

    – While I’m at it, in general it would be nice for “dimmers” to also be able to toggle from the app without having to drag the slider – I would suggest that perhaps touching the light icon would toggle its state rather than going into edit mode, or add a small “switch” icon beside the dimmer slider. That’s probably a much bigger request, but I have quite a few dimmers and it would be nice.

    Thanks again for adding support so quickly!
    😀

    Anonymous
    Post count: 259

    Appreciate the feedback. These tasks were not time consuming, so decided to do this in between breaks 😉

    — The issue with dimmer % mismatch is that the App is probably requesting the status too soon. [Should be fixed now]
    — Metering should also display kWh and kW now. [Don’t have the device, so you will have to confirm for me ;)]

    Please restart the App and let me know if there’s any issues.

    Anonymous
    Post count: 19

    It was hard, but I patiently waited until the girls were done this afternoon to play again. It does indeed display the kWh and kW now, that’s great!

    A few other things I noticed:
    – The dimmer swipe down to 0 now indeed goes fully to zero, that is fixed, thank you.
    – The dimmer swipe up still stops on 95% until I swipe again. This is really no big deal… (In case it is useful info – the same thing happens if I swipe up to 50% – it displays 45% until I swipe again to 50, or any other number swiping up, it always subtracts 5% and stops there.)
    – The kW/kWh display is not updated until I manually hit refresh – but this might be by design? Again, no biggie.
    – With my other dimmers (Centralite) I can set the “transition time”, but this one does not save that info properly… perhaps using the default info from another device still? Would be nice to have since a 1-2 second transition time is a very nice effect smooth effect.
    – “On level” on that same screen works fine and saves properly.
    – I see that I can specify wizards to fire based on kW and kWh usage, awesome. I’ll play with that soon. Even at 100% brightness all 9 LED lights that are loading this dimmer only consume 0.160kW. No way to know how accurate that it, but since 160/9 ~= 18W and that’s about what I remember these being rated for, I’ll assume it is accurate. Is there any way to “reset” the accumulation number?

    Thanks again, Dhawal. 🙂
    😀

    Anonymous
    Post count: 259

    It was hard, but I patiently waited until the girls were done this afternoon to play again.

    😆

    – The dimmer swipe up still stops on 95% until I swipe again. This is really no big deal… (In case it is useful info – the same thing happens if I swipe up to 50% – it displays 45% until I swipe again to 50, or any other number swiping up, it always subtracts 5% and stops there.)

    Will need to play with the device to understand this, something silly related to App slider.

    – The kW/kWh display is not updated until I manually hit refresh – but this might be by design? Again, no biggie.

    If you want it to report automatically, then you can use the REST API and set the desired params.

    – With my other dimmers (Centralite) I can set the “transition time”, but this one does not save that info properly

    Something related to device, again would have to experiment with actual device and understand the problem. [will have to be added to backlog]

    – I see that I can specify wizards to fire based on kW and kWh usage, awesome. I’ll play with that soon.

    Cool let me know. You may need to setup reporting if its not already setup, otherwise this may not work perfectly. I’m not sure but i think ZBPServer tries to set it up automatically, though you may want to check the period or report on change in value just in case.

    Even at 100% brightness all 9 LED lights that are loading this dimmer only consume 0.160kW. No way to know how accurate that it, but since 160/9 ~= 18W and that’s about what I remember these being rated for, I’ll assume it is accurate.

    Sounds right 🙂

    Is there any way to “reset” the accumulation number?

    Not through the App. Other options:
    1. Factory reset the device and join to network again
    2. Try ResetToFactoryDefaults command with REST API

    Thanks a lot for detailed feedback, appreciate it.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.