Flash Interface Device Icons Problem 2009-12-20T01:59:48+00:00

HOME Forums Gateways EZSrve Flash Interface Device Icons Problem

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • Anonymous
    Post count: 5
    #40236 |

    I have been trying the new Harmony flash interface (version 0.21.4) and do not get the device icons (light bulb jpg) in the area page. The area page does allow new devices and device modifications, but does not show any device graphics to choose with the modify graphic option. It does accurately show the on/off/dim level. The only area icon (picture) that I can get is the default house for the all devices area. The jpg files do show up in the program files with the default house jpg.

    I did get a clean install, but was having trouble signing in with ezserve 2.06 and updated back to 2.05 which seems more reliable in both harmony and the html interface.

    Anonymous
    Post count: 1001

    Each device definition no longer comes up with a specific icon. Double click on the device entry, select the “MODIFY DEVICE RECORD – Change Image” option, select the image Icon desired from scrollable list displayed at the bottom, click on Proceed. I have changed some of my device definitions this way and once changed will be displayed with the selected Icon each time. However, when I tried this on 0.26.0 the process “Timed Out”. With the Harmony client in Beta status things like this will sometimes happen.

    Regarding the EZSrve image level, there is a 02.06.04 image available under the Java Discovery Tool 1.1 which has been stable in my environment for weeks. It contains collective fixes that have been developed for the 02.06 image. I would suggest going to this level rather than staying on 02.05.

    Anonymous
    Post count: 5

    In the Harmony download version 0.21.4 I have the modify image radio button, but it does not show the scrollable list below. That area is just blank.

    In the online Harmony version 0.26.0, I do see the scrollable list and can pick a picture, but it times out in the proceed operation.

    I will try the 2.06.4 version. 2.05 is giving me intermittent PLM not available messages, but seems to work if you ignore them.

    Anonymous
    Post count: 1001

    In the Harmony client evolution the 0.21.4 version is pretty old. That is the limitation of running the AIR version. Will be a good option once the Harmony client is finished but with as often as the server based Harmony client is updated during Beta development, the AIR version will be down-level most of the time.

    The 02.06.04 image resolves a number of problems with Actions. Another user running that image level found it resolved his Actions problem and was generally stable. It will not resolve the Harmony Icon problem. From the Docklight trace it looks like the Icon problem is totally within the Harmony client itself.

    You can update the Icon image manually but it requires the Devices.xml file be edited manually. The Pic= tag contains the name of the .png Icon file (Pic=”DefLampB1.png” as example taken from my Devices.xml file). Placing the cursor on the Icon displayed in the scrollable list shows the file name in the context help display. The Pic= tag can be changed to that name. I’m certain this problem will be resolved in an upcoming update to the Harmony client.

    Anonymous
    Post count: 1001

    The Device Icon change is now working.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.