Firmware 1.30 Release 2008-02-16T00:47:34+00:00

HOME Forums Gateways EZSrve Firmware 1.30 Release

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • Anonymous
    Post count: 408
    #39866 |

    It is now available under the downloads section.

    The Image:
    http://www.simplehomenet.com/Downloads/image.bin
    The Release Notes:
    http://www.simplehomenet.com/Downloads/EZSrve_Release_Notes.pdf

    Some highlights: make sure to clear your browser history and cookies.
    We went through very thorough testing – there are some minor known issues, but please let us know about your experiences.

    Additional Functionality:
    · 9-Hour Timeout Period after Login
    · Added new I2 devices
    · Added ability to see Sunrise / Sunset in Location Area
    · Increase in brightness level option (by 20%) in View Areas screen

    Issues addressed in this release
    · Password Management
    · Adding a device without a link
    · Adding devices the wrong devcat was read
    · When adding a device, the dialog box asked for the Insteon ID
    · Unable to add X10 device
    · Device status not always reflected
    · Timezone settings impacting Sunrise / Sunset

    Minor changes addressed in this release
    · Removed popup after polling devices
    · Ability to use underscore character in timers name
    · Added a verification to ensure the device is not in an area prior to deletion

    Known Issues
    · Image.bin cannot be located under some directories, while it can on others
    · Network settings may be reset after an upgrade
    · Depending on security settings of the browser and the machine, it may be necessary to refresh the page to see a change in status after polling

    Anonymous
    Post count: 57

    Paul:

    Surprised by the speed of the release, and except for one little thing I found, it looks really good!

    Only thing I’ve found so far is trivial: IconAppl-Adapter shows “ON 99%” when it first gets turned on… at some later time it switches to “ON 100%”???

    The device is returning (last 3 bytes of InsStdMsg response to command 0x19)
    0x20, 0x01, 0xff where the ApplianceLinc returns 0x23, 0x04, 0xff…

    oops – one more trivial (or need to doc) Password only accepts alphanumeric – no special characters….

    thanks for the speedy fixes
    edc

    Anonymous
    Post count: 18

    Before I upgraded to 1.3 from 1.2, I did a reset to factory defaults via the web interface.

    After loading the 1.3 firmware, the areas that I was using under 1.2 are still visible. However, the devices that went in those areas are not.

    I like that the sunrise/sunset times are now displayed – I’ve never been able to get them to work, but now I see they are correct.

    As with the areas being maintained from 1.2 to 1.3 (even after a reset via the web page, as noted above) the lat/lon is maintained as well.

    When adding devices, it appears you can’t just give it the device address – you still need to press the link button on the device. Unlike previous versions though, it doesen’t seem to pop up that dialog that instructs you to press the button.

    Anonymous
    Post count: 57

    Paul:
    I tried the save & restore from file, and it _sort of_ works…. however, after you’ve uploaded a file, you get this message:

    XML file upload successful! Restart to see the
    changes once you complete all the uploads.

    However, the only way I can see from the GUI to “restart” is the “Reset” button, which does indeed do “return to factory defaults” that it claims. (well, almost – it clears the password, timers and in my case the device list (as shown in the devices page and the area page – although the actual “area” that I had defined is still there, with nothing in it.))

    I have tried restoring the devices and the devicelinks, but they don’t reappear.

    Oddly, the timers seem to be working fine even though there aren’t any defined devices.

    I’ve tried re-uploading and then using SHN to issue the “reset” command (which the docs indicate is just a reset, not a return to factory defaults…)

    Also using SHN, I can see the timer list fine, but issuing the LstDevices gives me one essentially empty entry, and sending the GetLnk followed by some GetNext shows 8 linked devices, which matches the number of items I have under timer control. (The GUI’s Link List button also shows no entries”)

    So – getting closer, but still not done.

    thanks
    edc

    Anonymous
    Post count: 408

    The problem is in the documentation.

    After you reload the files, it should say restart the module (cycle power) – when you press the reset button, it clears the data bases.

    We are going to be adding a restart module on the next release and clarifying the text in the popup.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.