EZSnsRF/Dakota and EZServe linking 2008-08-21T16:59:18-07:00

HOME Forums Controllers EZSnsRF EZSnsRF/Dakota and EZServe linking

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • Anonymous
    Post count: 20
    #40042 |

    Want to have EZServe turn on lights on a toggle linc, only at night when triggered by either two of my Dakota sensors. I can not figure out for the life of me how to get the web utilty to link to each of the sensors, or the sensors to the EZServe via the EZSnsRF. I would appreciate a link or info, that specificly helps me with this combo.

    EZSnsRF devices currently linked directly to Togglelinc. Can link Togglelinc to EZServe, but not Dakota devices through EZSnsRF to EZServe

    Post count: 1001

    This may sound a little convoluted but it should work. The problem is I don’t know how to relate the Dakota Alert frequency/zone value to the “code” that would have to be entered using the Utility. I follow the Set button linking technique described in the EZSnsRF doc which you must have already done for the motion sensor to turn on the Togglelinc. Use the Utility to display the link record(s) in the EZSnsRF to determine the Group number being used by the “Controller of” link record pointing to the Togglelinc. The relationship of the Dakota Alert frequency/zone to Group number was established during the Set button linking process.

    Add the EZSnsRF device to EZSrve, selecting NO link be established when the device is added. Use EZSrve Scenes Management and define a Scene where the EZSnsRF device is the Controller and the Unit number is the Group number determined above by looking at the existing link between the EZSnsRF and the Togglelinc. Add the EZSrve as the responder for the new Scene.

    Now define an EZSrve Macro….
    Then device: the EZSnsRF device name
    Does: ON
    Unlabeled Input Field to the Right of Does ON: enter the Unit number
    of the Scene you created with EZSnsRF as the controller.

    When: Between Sunset and Sunrise
    Then device: the device name of the Togglelinc
    Does: ON

    When the Dakota Alert motion sensor sends its code to EZSnsRF, EZSnsRF will send an ON command to EZSrve using the Unit number as the Group number. The EZSrve Macro should trigger as a result of this and turn on the Togglelinc, only between sunset and sunrise.

    The Dakota Alert motion sensor will send its OFF message to EZSnsRF soon after motion is no longer detected. You need another EZSrve macro which triggers with a Does: OFF from EZSnsRF to turn off the Togglelinc. You can use the After Delaying: option to establish how long the Togglelinc will stay on after receiving the off message from the motion sensor.

    When all that is working, use the Utility to delete the link that was originally established with the EZSnsRF Set button.

    Post count: 20

    Followed most of that…

    But have question regarding scene number

    “enter the Unit number
    of the Scene you created with EZSnsRF as the controller.”

    I do that (in this case unit number 01) and hit save, but the field goes blank after I hit save, leading me to believe something I did is wrong, or not working. 😥

    I tried looking at the links in the EZServe using the homenet suite utility, Using –>Manage device Links –>Display existing link records,
    but the utility doesn’t seem to like my ezserve. (I get insteon message timeout) and this shows up in the sent tab. (06.4C.D8 is my ezserve)
    To ID:06.4C.D8 flags:0F cmd1:28 cmd2:F
    To ID:06.4C.D8 flags: cmd1:28 cmd2:F
    To ID:06.4C.D8 flags: cmd1:28 cmd2:F
    To ID:06.4C.D8 flags: cmd1:28 cmd2:F
    Huhm message isn’t showing correctly in preview, but where APP is, should say APP RETRY in above lines

    In the web interface under:
    Device managment –> EZServe –> Link Records
    I get this:
    Controller of FP Toggle Link on Unit 01 – Data:00-00-00
    Responder to EZSnsRF on Unit 01 – Data FF-1A-01

    This shows under the EZServe Database List scenes.xml
    Scenes Default_01EZServe01FP Toggle LinkFF-1F-00 Dakota1EZSnsRF01EZServeFF-1A-01

    I get nothing showing in devices3.xml

    And this under macros
    Macros 0DriveWay0D.FC.82ONC111C2FFS+R00:0011111110C.B4.BAONC111C2FF00:00:00

    Thanks for the info to date!

    Jeff 🙂

    Post count: 1001

    First, my apologies, the Macro facility does not recognize the Unit number of the If Device. I actually tested this variation with a Keypadlinc button 6 (group 06) and it worked. The macro did turn on the Then Device as I expected when I pressed button 6. However, after you questioned the value not staying in the field I checked further and found that any Group number (any button on that Keypadlinc with a link back to EZSrve) also triggers the macro and turns on the Then Device. I’m afraid I got ahead of implemented function. If you only have one Dakota Alert code defined to EZSnsRF, that is both motion sensors are using the same frequency/zone setting, the respective Macro should trigger with the ON/OFF commands coming from the EZSnsRF. However, if you intend to have each motion sensor on its own zone and or frequency, where the EZSnsRF would be using more than one Group number, the EZSrve macro facility will not differentiate between the groups. I pulled one of my Dakota Alert Motion sensors out of storage and will set up that specific test to be sure I can trigger a Macro from the EZSnsRF when the motion sensor activates.

    You cannot use the Utility to look at links in the EZSrve link database when the Utility is connected to the powerline through EZSrve. If you have a PLC, connect the Utility through the PLC to look at links in EZSrve link database itself. The EZSrve link database is not the XML files EZSrve manages. The Utility sends Insteon messages on the powerline to a specific device to view the contents of that devices link database. The problem is the address of the Insteon device in this case is the EZSrve itself. EZSrve cannot put an Insteon message on the powerline that requires itself to respond to that same message.

    Update: Testing confirms that an EZSrve macro will trigger from an EZSnsRF ON and OFF command resulting from motion detected by a Dakota Alert PIR. I set a 2 minute delay in the OFF macro definition so the device controlled by the macro turns off 2 minutes after the PIR sends the off signal.

    Post count: 20

    Eagerly waited on software update. Installed 1.58. Now I get “Link couldn’t be created with device. Add without?” When I answer yes, to question, The device shows up as other.

    What am I doing wrong.

    I am able to communicate and interogate both devices with smart suite.

    Post count: 1001

    Image 1.58 introduced the means for triggering a macro on a Group message from a specific Virtual Input. The message at device add was not addressed by 1.58. When the first question about linking is presented, select No, the device will be added, the device type will be preserved.

    EDIT2: the inability to put a responder link in the EZSnsRF at device add time does not affect the ability of EZSrve Scene Management to add links between the EZSnsRF and EZSrve later on.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.