EZServe fails to update time after power failure 2010-06-06T18:40:42+00:00

HOME Forums Gateways EZSrve EZServe fails to update time after power failure

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • Anonymous
    Post count: 12
    #40268 |

    My EZserve does not recover the date and time after a power failure. It seems that my router and cable modem take a few minutes to recover after a power failure. During this time, the EZServe may be trying to access a network time server and failing. After that, it never seems to be able to retry. I think I saw a post a while ago claiming that it should retry every 24 hours, but this is not working for me.

    Friday night I tested it: shortly before midnight, I simulated a power outage: I pulled the plug on the router, cable modem, and EZServe, then reconnected them all at the same time after about 5 minutes. Now it’s 11:30 Sunday morning, and the EZServe time is set to 23:50 1/2/2009, pacific std time.

    When I try to restart just the EZServe alone, either by a power cycle or using the RESTART in the GUI, it works fine. It’s only when the cable modem and router are restartingl that the EZServe fails to get a time update.

    I have a fairly simple all-Insteaon automation setup, a few lights and a timer. I need it to work reliably. We’re heading into the warmer weather season, with frequent power outages. Any suggestions to make this work?

    Anonymous
    Post count: 1001

    We have seen the situation where the router/internet modem is slower to come up such that the EZSrve cannot connect with an NTP server. I keep the modem (has built in router) on the same UPS as the PC so when power goes down I can still use the internet. When the EZSrve comes up after a power failure it has a functional internet access.

    Check the time options on the EZSrve. Be sure the NTP option is still set after a power cycle. I don’t know when the EZSrve normally does a time sync but I should be able to set up a wireshark trace. Of course it will be relative to the time the EZSrve thinks it is rather than actual clock time.

    Anonymous
    Post count: 12

    When the EZServe starts, the Date and Time is set to Pacific Std Time NTP enabled, 12:00 1/1/2009.
    I just tried restarting it with the cable modem off. I waited another minute, then turned the cable modem back on.
    It still hasn’t picked up the current time.

    Is there no way to make the EZServe retry to access an NTP server at periodic intervals if it fails to do so? This seems like a huge flaw in its programming.
    I don’t plan on getting a UPS just to keep the EZServe running.

    Thanks.

    p.s. my EZServe has Ver 2.06 firmware, and PLM Ver 62.

    Anonymous
    Post count: 1001

    I am running the Beta 02.06.12 but I did not think there was a fix in this area. I run with Eastern Std Time selected, Daylight Saving checked and NTP selected. When I unplug EZSrve and restore power it comes up with the correct time for the specified time zone adjusted for daylight savings.

    After setting the Time Zone you want and the NTP option, click on SET TIMEZONE button. Otherwise the changes are not permanent.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.