EZRain1 Product Key Response Message 2007-12-13T23:19:30+00:00

HOME Forums Irrigation EZFlora EZRain1 Product Key Response Message

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • Anonymous
    Post count: 20
    #39822 |

    I’m trying to interrogate devices using cmd 0x03 0x00 (Product Key Request)
    I’m getting weird values from the EZRain1.
    (according to the Insteon Dev Guide, Chapter 8, Page 139 ED Product Data Response)

    EZRain1 response compared to ED Product Data Response:

    02 51 08 9B 62 AA AA AA 36 03 00 blah blah standard stuff

    00 D1 – Always set to 0x00
    00 D2 – Insteon Product Key MSB
    01 D3 – Insteon Product Key 2MSB
    00 D4 Insteon Procude Key LSB
    00 D5 Device Category
    00 D6 – Device Subcategory
    00 D7 – supposed to be FF
    00 D8 – supposed to be FF
    00 D9-D14 – User defined

    Something doesn’t add up here..

    According to the Dev Guide, Chapter 7 Page 89:
    the EZRain1 is:
    devcat 0x04
    subcat 0x00
    Product key: 0x000001
    which SHOULD be reported as:
    (starting at D1)
    00 00 00 01 04 00 FF FF 00 00 00 00 00 00

    Am I missing something?

    Thanks,

    Dan

    Anonymous
    Post count: 20

    The EZX10RF reports back as it should.(proper ED Response)

    The problem is also in the EZIO8SA.

    Anonymous
    Post count: 20

    I was able to get the Cat and SubCat from 0x1000. Although I was able to overcome my problem, this should still be corrected.

    Thanks.

    Dan

    Anonymous
    Post count: 256

    Dan, what EZrain firmware version do you have? Since introduction, EZRain has had to accommodate many versions of the PLM, from the original 1.x that did not have a links databse to the currently shipped 62. Extended messages were only supported by the PLM starting with version 52. The product data key message is also fairly recent and we implemented it in EZRain starting with version 2.0. We’d be happy to upgrade your unit.

    Al

    Anonymous
    Post count: 20

    Good Question! I haven’t checked the firmware version of that…

    Although, I think I’d be more interested in making it work as it is…

    I’m developing code that could potentially be used by 1000’s and I don’t want to force them to have a specific revision..

    I probably will take you up on that offer, but I’d like to get around it first. 🙂

    Is there any way to ‘sample’ the different firmwares? to test compatibility with my LinuxMCE drivers…

    BTW, I’ve found similar oddities in Smarthome’s products as well..

    Anonymous
    Post count: 256

    Dan, have you tried the “start linking” message? This should elicit a “pushbutton pressed” message by the EZRain that contains the ID and devcat. You can then follow it with a “stop linking” message.

    Al

    Anonymous
    Post count: 20

    I found another way around it…
    I issued a PING to it..
    that worked.

    Thanks for the reply though!

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.