EZIO40 Power Supply Fix 2015-04-24T02:04:06+00:00

HOME Forums Input/Output EZIOxx EZIO40 Power Supply Fix

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • whistlepigger
    Post count: 1
    #40469 |

    I purchased an EZIO40 2 years ago, plugged it in, configured it with my ISY, and then never got around to using it. Today I noticed that the LED was off, and I was unable to access from the ISY. I tried plugging it in to different power, but no joy – the LED light would not come on, and the EZIO40 was not visible from ISY.

    When I called support, they suggested that it might be the PLM, and suggested I send it back and they would investigate. However, since the EZIO40 was not under warranty, there would be some cost.

    I decided that since it was out of warranty, I’d open it up the device and take a look inside. To my surprise, the EZIO40 mainbaord is a 2413x – similar to the one inside the Insteon 2413S PLM. Even more coincidental is that last year, my Insteon 2413S PLM failed in the same way, and I was able to repair it for about $5 by replacing 4 of the capacitors. That same fix worked for the EZIO40, and it is now operational again!

    When I searched this forum, I found no reference to this issue – and no mention of the fix. So I wanted to post for anyone who has this problem. Search the ISY Universal Devices forum for “Repair of 2413S PLM When the Power Supply Fails”.


    Post count: 192

    I have a 2443 Access Point. Hardware version 2.5.
    It is built on the same base 2413S PLM board. It died this morning and I also suspect the poor choice of capacitors is the cause.
    I have rebuilt my 2413S as it died earlier this year.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.