Can not log on to EZserve GUI from virtual IP 2007-08-16T14:41:06+00:00

HOME Forums Gateways EZSrve Can not log on to EZserve GUI from virtual IP

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • Anonymous
    Post count: 10
    #39759 |

    Now that I’ve got the right UserID and PW …Thanks Russ I’m having a problem logging on to EZserve GUI from virtual IP using a private port (8002) it times out If I use the old Ezbridge interface it will connect using the virtual IP with the private port 8002. Note I have 5 web camears and 2 NAS boxes that have no problems with the way I set up the virtual IP’s and private ports.

    Anonymous
    Post count: 18

    Hi,

    Haven’t really tried much with the EZServe yet (just plugged it in last night) but if I understand what you are trying to do is use the EZServe web GUI from behind a firewall/NAT/router device?

    I’ve not really tested it much, but I can get to the GUI from outside my home network by forwarding a port (any usused port should work) from the public/Internet side of my router to the internal IP address of the EZServe. Different routers/firewalls may require you to also specify port 80 (http) for the EZServe GUI as well as the internal network IP address.

    Don’t know if that helps much, but I can verify that I can get normal GUI access through a router/firewall/NAT device.

    -Russ

    Anonymous
    Post count: 10

    Hello Russ,

    Thanks Again for your update. Yes I’m trying to do is use the EZServe web GUI from behind a firewall/NAT/router device using port 8002 (which works on the old Ezbridge inface). Question, when you log on to the GUI from a remote location what port are you using and does it ask you for userID and password. Also did you have to set up the GUI (house keeping)..IP address, PW port…etc before you could log on to the GUI from a remote location?

    Thanks
    Don

    Anonymous
    Post count: 18

    Hi Don,

    I don’t have a before/after comparison to benchmark my experience against like you do, but when my EZBridge came back as an EZServe last night in tha mail, all I litterally did was plug it back in. I haven’t changed anything beyond what was in there from the factory. I’m still using DHCP, but told my router (it assigns IP addresses on my network) to always assign a fixed IP address to the EZServe’s MAC address.

    My setup sort of looks like this:

    public IP: 111.222.333.444 (just an example – not a real address)
    EZServe static IP: 192.168.2.156

    On the EZServe web GUI, the port (by default) for http activity is port 80.

    Most ISP’s block incoming port 80 (or, you may already have another service running on your public IP’s port 80) so let’s say we want to use another port, 8898 (this can be any valid unused/unblocked port on your public IP’s address).

    So, what we would do is map 111.222.333.444 port 8898 to 192.168.2.156 port 80 in our router – typically via the router’s GUI.

    Now, when you want to get to the EZServe’s web GUI from outside your local network, just type the following in the address bar of your browser:

    http://111.222.333.444:8898

    and you should at this pont see the usual user/password dialog.

    So, to answer your question, yes, I do get the same user/password dialog, and although it doesn’t really matter as long as it’s unused/unblocked, I used port 8898. I also did not change anything in the EZServe as far as IP addresses either (although I did get the same effect as a static IP by forcing my router to pass a fixed IP to the EZServe when it makes a DHCP request).

    Hope my ramblings help and not confuse…

    -Russ

    Anonymous
    Post count: 10

    Hello Russ

    It looks like your using the same logic as I have been doing to define my virtual IP address. The only thing that is not clear is other than defining the virtual IP with the port in your router where is the port (if you change it from 8002) defined in the EZbridge?

    Thanks
    Don

    Anonymous
    Post count: 18

    Hi Don,

    Maybe you are confusing the GUI http service port (80) with the XML (8002) service port?

    The EZServe responds to web GUI requests by listening to port 80 of it’s IP address and ALSO responds to XML requests by listening to port 8002 of it’s IP address. If you want to be able to do both things (and this depends a great deal on your router’s specifics) you need to map both ports (80 and 8002) between the public IP of the router and the private IP of the EZServe.

    111.222.333.444:8898 -> 192.168.2.156:80 (for html / GUI interface)

    AND

    111.222.333.444:8897 -> 192.168.2.156:8002 (for XML interface)

    Sometimes there is also a so-called “DMZ” setting or “server” setting in routers that allow a private IP to be entirely exposed to the public network. This feature can be handy for troubleshooting or sanity checking network connectivity, but generally not a good idea to do as there is no firewall protection between your DMZ device and the Internet at large, plus will also reduce your flexability in network configuration.

    The purpose of firewalls is to keep the outside network traffic out, but when you need to let some unsolicited traffic in, these protection features can really work against you…

    -Russ

    Anonymous
    Post count: 10

    Hi Russ,

    It works! that was it now I have a public port of 8002 and a private port 80. Not sure were you got the information but thanks.

    Don

    Anonymous
    Post count: 18

    Hi Don,

    Glad it works!

    No real secret info source other than Google for the default user and password guess, and the networking walk-thru is just based on my own struggles over the years…

    Good Luck!!

    -Russ

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.