Can not Activate EZIO2x4 Alarm Setting 2008-05-03T13:09:28+00:00

HOME Forums Input/Output EZIOxx Can not Activate EZIO2x4 Alarm Setting

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • Anonymous
    Post count: 47
    #39936 |

    I am using an ATS2000a Temperature Sensor connected to Analog 1 of the EZIO2X4. Using the SHN utility I am able to monitor the Analog values which register at about 289 at room temperature and vary by about 4 per degree.

    For the linking device I am using a LL, which was linked to the EZIO2X4 using the button/Tap method.

    I have tried various trip point values and have crossed those by a wide margin in both directions. If I monitor the Insteon Traffic as the trip point is crossed, there is absolutely no activity.

    Here are latest settings I used, which were read via the SHN Utility:

    Configuraton Register:
    Enable Analog Inputs = Checked
    Continuous A/D Conversion = Checked
    Broadcast on Status Change = Checked

    Sensor Alarm Settings:
    Input = Analog 1
    Off to On = 285
    On to Off = 276

    All_Link Group Commands:
    Input = Analog 1 / Alarm
    Group = 3
    Timer = 0
    Actuate Output = Unchecked
    Ignore On to Off = Unchecked
    Off to On: CMD1=11 CMD2=0
    On to Off: CMD1=13 CMD2=0

    Link Records as read from the SHN Utility:

    EZIO2X4 (08.9C.67)
    Link Record 1 – Controller of Device: 4.9F.DE; Group 3; Data: 1,0,28

    LL (04.9F.DE)
    Link Record 1 – Responder to Device: C.AF.2C: Group 0; Data FF,1F,0
    Link Record 2 – Responder to Device: 8.9C.67; Group 3; Data FF,1B,0

    At this point I could use some suggestions as to how to proceed next.

    Thanks,
    George.

    Anonymous
    Post count: 1001

    You might update your post with information regarding how you are monitoring Insteon traffic. i.e. the SHN utility would not show the Insteon messages for the EZIO2X4 state change.

    EDIT: sorry for such a cryptic post, was running late this morning. The “Insteon Traffic” tab is NOT a generalized Insteon trace facility. The left side of the Insteon Traffic screen shows the commands that the utility is/has issued to perform the requested utility function. The right side of the Insteon Traffic screen shows the Insteon response to each of those commands. It does not show Insteon traffic that is generated outside the utility.

    After the SHN utility has connected to the PLC, there is an ICON in the system tray that looks like a blue T. This icon represents the Smarthome Device Manager (sdm3) that the SHN utility, and other programs, use to interface to the PLC. A double click on the blue T icon will open the sdm3 trace window, which does show Insteon traffic. Not every Insteon message that flows on the powerline is traced but it will show most of what is happening. Often an ACK to a Group Cleanup Direct occurs too fast for the PLC/sdm3 to trace the message.

    Anyway, if you were using the SHN utility to conclude no Insteon traffic flowed at the trigger point, rerun the test with the sdm3 trace window open.

    Anonymous
    Post count: 47

    Yes, you are correct. Actually, I keep both open. I type DM in the Device Manager window, so I can access the CLEAR button in order to clear out the prior traffic messages before I run the test.

    Anonymous
    Post count: 1001

    Let’s hope someone following this has the answer. Your configuration (except for the actual sensor itself) is the same as mine except for the Broadcast on Status Change. The Broadcast on Status Change option is used when you don’t have a link associated with the Input and you want the 2X4 to send a “Status Changed” (0x27) Broadcast message when the state changes. The existence of a link should override that option and cause the ON/OFF Group Cleanup Broadcast. I turned that option on in my 2X4 and it continues to send the ON/OFF Group Cleanup Broadcast messages as expected. The only thing I can think of is to add the firmware level of your 2X4 from the SHN Utility display to your post information. My 2X4 is V25 which was the latest a few months ago. Perhaps someone at SHN will know of something at your level if it is below V25.

    Anonymous
    Post count: 47

    grif091,

    Thanks for all your help. I finally have it working now. To be honest I am not sure exactly what the problem was. My firmware is v26 which I just updated recently. I went back and checked that IN1 would still trip R1. Then I went back and checked all the settings for Analog 1 again.

    This morning the Group number for Analog 1 was set to 2 instead of 3 and I am pretty sure I saw it set to 3 last night. I also checked each of the other Link Command settings and performed a WRITE. I frequently get timeout messages, so I confirm any changes I make by doing a READ after any WRITE command I make. If I get any timeout errors, I repeat the READ.

    I don’t see how a wrong group number could explain why I was not seeing any insteon activity in the DM, but obviously one of my settings was incorrect. Perhaps writing values for Input1, Input2, Analog1/Alarm, and also Analog2/Alarm solved the problem.

    Anonymous
    Post count: 1001

    Glad to hear you are working. The Input group number is used to search the link database looking for a “controller of” link record with a matching group number. A “controller of” link record with a matching group number provides the responder device Insteon address needed in the Group Cleanup Direct message. Without a match of group numbers, the 2X4 does not have the responder address needed to issue a Group Cleanup Direct message. Without at least one matching link record, the starting Group Broadcast message is also not sent.

    Anonymous
    Post count: 256

    For details on the different functions and the settings for the inputs, please see the updated command reference document. This has been renamed “EZIOxx Advanced Details and Command Set”

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.