ailing EZX10… 2007-12-09T06:05:54+00:00

HOME Forums Controllers EZX10RF ailing EZX10…

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • chejlava
    Post count: 57
    #39818 |

    I have an EZX10 that is about a month old. It’s been working OK – but today when I tried to add a couple of more Insteon devices to a new group it seems to have gone off the deep end.

    I’ve tried clearing it several times, reprogramming it via the Utility, reprogramming it the old-fashioned way and I’ve come to the conclusion that it is not long for this world.

    Latest symptom:
    I’m trying to set it so that:
    X10 Insteon unit

    C1 #1
    C2 #2
    C3 #3
    C4 #4, #5
    C5 #6, #7
    C7 #8

    When programming the manual way, the first couple of links go OK, but after the 3rd or 4th, things start getting cross-linked or non-linked.
    i.e. I#3 responds to C1 and C4 for ON, but C3 for OFF.
    I#4 and I#5 don’t respond to C4, but I#1 does most of the time

    It is also becoming somewhat flakey when using the Utility – it often is needing many retries and for a while it was totally uncommunicative (but it “got better”…)

    Is there any trick to __really__ clear the memory out? Using the “Restore Factory Configuration” button or doing the “hold the button for 12 seconds while plugging it in” don’t seem to clear everything – reading the Code Records still shows the X10 house and unit codes and group numbers that were in there before the reset. Maybe a firmware reload?

    Mine has code v14 in it.

    Also – if it is truly on the way out, I note that returns web page indicates that I need to return it in the original packaging – which of course went into the recycle bin once I got it working the day I got it…. is that really a requirement?


    Post count: 57

    …user manual for the ApplianceLincs that I bought – I just found out that I really didn’t need the EZX10RF!

    The ApplianceLincs can be set to respond to an X10 address natively……and since that is what I was looking for the EZX10RF to allow me to do (i.e. control the new Insteon boxes with my old X10 controllers)…..

    Oh well…that’s the price I pay for _not_ RTFM….


    Post count: 256

    We don’t want you to feel cheated. We’ll be glad to give you full credit if you want to apply it to any of our products..
    Just call our support line and ask for an RMA.
    We’d also be glad to repair/replace the module in case you want to use it. Think of the convenience of doing groups with an inexpensive remote control. It is more than you can do with just X10 compatibility on the ApplianceLincs.


    Post count: 57

    Well! I certainly don’t feel cheated at all – it was me who didn’t do his research, after all…

    But I think I will take you up on the swap offer – the EZBridge looks like it could be fun to play with!

    I’ll call next week for the RMA.


Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.