Reply To: EZeye & EZIO6I 2017-12-21T22:15:33+00:00

HOME Forums Input/Output EZIOxx EZeye & EZIO6I Reply To: EZeye & EZIO6I

Anonymous
Post count: 82

I just got this reply from Perceptive Automation”

Re: EZeye & EZIO6I
SimpleHomeNet wrote:
Are the Inputs linked to the Indigo PLM or are you using the Broadcast Status Chg option to report state changes. Also if using the Broadcast Status Chg option when not using Analog 1 in Analog mode, when the Enable Analog Inputs option is set is the Broadcast Status Chg option also being set.

Indigo always enables the Broadcast Status Change option. It does not link the individual inputs back to the PowerLinc, but instead relies on the broadcasts occurring.
SimpleHomeNet wrote:
The full Configuration Register is set when any option is set so it is necessary for Indigo to set all the options that are desired when any one option is changed.

Indigo does do this. Here is an example showing the raw commands sent when the analog input option is disabled:

CODE: SELECT ALL
Debug SENT: insteon 0F.9D.D7 05.06.2E 00 4D 40
Debug RCVD: insteon 05.06.2E 0F.9D.D7 21 4D 40
Debug RCVD: ack from 05.06.2E for command 4D 40
Sent INSTEON “_ezio8sa_” write configuration flags (received: 40)

Debug SENT: insteon 0F.9D.D7 05.06.2E 00 4F 01
Debug RCVD: insteon 05.06.2E 0F.9D.D7 21 4F 01
Debug RCVD: ack from 05.06.2E for command 4F 01
Sent INSTEON “_ezio8sa_” finalize i/o device EEPROM changes

And here is an example with analog inputs enabled:

CODE: SELECT ALL
Debug SENT: insteon 0F.9D.D7 05.06.2E 00 4D 41
Debug RCVD: insteon 05.06.2E 0F.9D.D7 21 4D 41
Debug RCVD: ack from 05.06.2E for command 4D 41
Sent INSTEON “_ezio8sa_” set analog input trip values
Sent INSTEON “_ezio8sa_” write configuration flags (received: 41)

Debug SENT: insteon 0F.9D.D7 05.06.2E 00 4F 01
Debug RCVD: insteon 05.06.2E 0F.9D.D7 21 4F 01
Debug RCVD: ack from 05.06.2E for command 4F 01
Sent INSTEON “_ezio8sa_” finalize i/o device EEPROM changes

Note in both cases bit 6 is set (0x40 and 0x41). I also re-verified that my old EZIO8SA sends out the status change broadcasts regardless of the state of the “enable analog inputs” option.

I replied with this:

Re: EZeye & EZIO6I
Simplehomenet says they can’t reproduce my problem and basically you say it should work as the Broadcast Status Change is enabled.

If the EZIO6I input #1 updates OK if ENABLE ANALOG INPUTS is not selected and then if the ENABLE ANALOG INPUTS IS ENABLED and this causes neither the #1 or #5 input or the Analog input to automatically update nor show any action in the Events Log can it be a problem with the EZIO6I?

Is there no way to manually link the EZIO6I to the PLM using the buttons on the sides of the units? If so how?

Also when I upgraded to 2414U I was never prompted for the driver. Everything other than this problem with the EZIO6I is working OK. Could the driver be the problem?

I’ve asked PA again if I can manually link the EZIO6I to the PLM 2413U. I would of thought if the Broadcast Status Change was working I would of had something in the Events Log.Can it be the EZIO6I is failing when asked to send Broadcast Status Change messages for both Analog & Binary?

Other than your utility is there anyway to link the EZIO6I to the PLM?

thanks,

bob