HOME Forums Gateways EZSrve Scene won’t stick when creating macro Reply To: Scene won’t stick when creating macro

Post count: 1001

The fact that linking a Scene did not complete suggests the EZSrve is having communication problems with one or more Insteon devices in the Scene. The only time I have seen this happen here was when I changed from Signalincs to Access Points and had the Access Points on the same phase. I figured this out by plugging the EZSrve into a good 50’ three prong extension cord and moving the plug end around until I had good communication. Not a solution but it did help analyze the problem. There was another thread where communication problems were resolved by adding a BoosterLinc, plugging the EZSrve directly into the BoosterLinc.

As far as having a Macro fire when an X10 signal is received, turning on a Scene, is working here under 1.52 so were looking for something unique about your configuration or environment. Perhaps trying something simpler to start with. I assume you have the X10 D02 device defined to EZSrve and that at least one of the SwitchLincs controlling the outside lights is also defined as a device to EZSrve. Create this Macro ….

If: X10D02name Does: ON
At: Anytime
On all days checked
Then: Switchlincname Does: ON

That is about as simple as a Macro gets. No Scene links required. The Switchlincname should be turned on with an Insteon Direct command.

Create an Area and add the Switchlincname to the area. Using the first screen displayed when EZSrve starts up, select the Area and be sure you can reliably turn on/off the Switchlincname. Do you have an X10 controller that can send the X10 D02 ON message. That would allow plugging the X10 controller closer to the EZSrve. Also do you have anything that traces the X10 and Insteon message traffic, like HouseLinc or PowerHome using a PLC. Knowing what X10 and Insteon traffic did or did not flow should help.

Can you post the Scene from the XML file that you are having trouble with.